1

After installing NVIDIA drivers I get a blank screen after grub. I've tried all remedies from related threads, such as this one, but the problem persists for me.


Edit: (Removed unneccessary clutter, added following)

If I boot into recovery mode and then select "resume normal boot", it works! How is that possible?

Based on the logs, it looks like it tries to load NVIDIA drivers from the encrypted hard drive before it is decrypted, and that is causing the error? This would also explain why booting via recovery mode works: in that case the drive is decrypted before NVIDIA drivers are loaded. I tried to install without full disk encryption and everything worked, so this is definitely related to encryption. Other people also experienced issues with full disk encryption + nvidia drivers. I tried these steps to make the password entry screen text-only, but it didn't work (I tried the steps before installing drivers and I was still seeing a graphical window for entering the password).

Also, in the successful boot I see only 1 "drm device card", but on the failed boot I see 2:

xfree86: Adding drm device (/dev/dri/card1)
xfree86: Adding drm device (/dev/dri/card0)
  • Can you still switch to a virtual terminal if X.org fails to start with the Nvidia driver? If so, could you please fetch the content of /var/log/Xorg.0.log and edit your question to include it? See askubuntu.com/questions/440087/… if you don't know how to do that with only a terminal. – David Foerster Dec 27 '17 at 17:17
  • Normally recovery mode is terminal-only which means X.org isn't started and its log files stay in place. Do you use full-disk encryption with passphrase entry during boot? – David Foerster Dec 28 '17 at 4:47
  • In that case, could you please try a more elegant work-around than what your own answer suggests: remove quiet splash from the kernel command-line in /etc/default/grub (and don't forget to run `sudo update-grub afterwards). That disables the Plymouth boot splash whose password prompt doesn't always work well together with Nvidia graphics drivers. – David Foerster Dec 29 '17 at 0:19
  • I tried that as well, but it's still trying to provide the graphical password prompt. I'm on a Gnome install right now, in case that makes a difference? – Atte Juvonen Dec 29 '17 at 12:11
  • I added the encryption tag. I also recommend that you go through some of askubuntu.com/questions/tagged/encryption+nvidia for similar issues. askubuntu.com/q/867643/175814 is what I recommended before (unsuccessfully, it appears). – David Foerster Dec 29 '17 at 15:16
1

Discovered workarounds:

  • Typing password at the blank screen works
  • Booting into recovery mode and then selecting "resume normal boot" works

My issue was caused by full disk encryption. I have another machine with full disk encryption + proprietary NVIDIA drivers and it works fine. I don't know why it doesn't work on this machine, but I confirmed the cause by temporarily installing Ubuntu without encryption. I suspect this issue was caused by 1 of 2 things and I'll award +1 and accepted answer to anyone who can tell me which (and how to fix it):

  • While my screen had a signal, it may have been drawing the password entry screen to my onboard graphic chip which isn't connected to anything (see logs)
  • Or perhaps the fallback to noveau drivers failed (after trying to load NVIDIA drivers from the encrypted partition)
  • I'm glad you found the issue after some of my poking at the right spots! Unfortunately this issue of the full-disk encryption password prompts with Nvidia graphics drivers is common. – David Foerster Dec 29 '17 at 0:16
  • Thanks for your help. I indeed found this because of your comments (you hinted at encryption being the cause, and I was in recovery mode trying to export the log files for you). – Atte Juvonen Dec 29 '17 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.