0

This question already has an answer here:

I'm using Ubuntu 16.04. When I try to install/uninstall Wine it doesn't work and I get the following results:

Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies::
 wine : Depends: wine1.6 or
                    wine1.8 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I already tried: sudo apt-get install -f and sudo dpkg --remove -force --force-remove-reinstreq

but I got this error message:

dpkg: error: conflicting actions -f (--field) and -r (--remove)

Type dpkg --help for help about installing and deinstalling packages [*];
Use 'apt' or 'aptitude' for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;

Options marked [*] produce a lot of output - pipe it through 'less' or 'more' !

I already read solutions in forums in English, but I think that my problem is different. In case you want to know, the broken packages are wine1.8.

marked as duplicate by David Foerster, waltinator, Eric Carvalho, George Udosen, ravery Dec 28 '17 at 14:13

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • current stable version of wine is 2.0.2 (Ubuntu 2.0.2-2ubuntu1). You haven't mentioned what command you are running to install it. Just in case you can use sudo apt-get install wine-stable – neferpitou Dec 26 '17 at 9:12
  • 1
    Looks like you tried to install Wine more than one way, and didn't clean up after each attempt. The installed packages left from previous attempts are blocking your current try. You cannot apt-voodoo you way out of it. You must revisit those previous attempts and clean up. – user535733 Dec 26 '17 at 13:28