Since morning today, my laptop has been freezing up frequently. Only option available at that time is to kill x-server(as ctrl-alt-backspace is the only thing which works that time). I checked "Task manager" and it shows "gnome-shell" process consuming upto 70% of CPU. What is going wrong and what can be done to fix it?

Update Issue happened again and i captured few snapshots, which shows the consistent CPU percentage consumed by 'gnome-shell' process. You can also check the "graph" on top-center, which is continuously touching the roof!

enter image description here

enter image description here

enter image description here


I've moved to Cinnamon Desktop. This problem was hampering my work productivity alot so finally made the switch and i'm pretty comfortable with it now.

  • After keeping the system idle for few minutes, the overall CPU consumption has gone down to normal level i.e. 13-30% – subeh.sharma Jan 27 '12 at 9:21
  • How about posting (and looking in) the output of ps -el? – Aquarius_Girl Jan 27 '12 at 9:24
  • Thanks, the issue has occurred 3-4 times now. Currently it has stopped after keeping system idle for couple of minutes so the output of "ps -el" doesn't show anything alarming. May be next time when it happens(and it happens quite frequently), i'll capture that. But from what I've seen, only gnome-shell process takes up bulk of CPU whereas others were only taking single-digit CPU %. – subeh.sharma Jan 27 '12 at 9:26
  • 1
    Is there a command which could show CPU consumption history? – subeh.sharma Jan 27 '12 at 9:27
  • 1
    'Top' doesn't show any history which was what I asked. It only shows you the real-time data of processes and their statistics, which i am already seeing in "Task manager". – subeh.sharma Jan 27 '12 at 9:49

I suffered the same problem (just using Gentoo/Linux as OS). Actually the gnome-shell-theme I used ("Transparent Atolm") seemed to create the problem. After rolling back to the default theme everything worked fine again.


I am having this exact same issue on my Dell laptop.I am using ubuntu-gnome 16.04.After two days i found that issue was intel graphics. i solved this issue by disabled secondary display.

setting->displays->secondary display->turn off. only primary display is acive now.that's all..........


Cheese running in the background was making gnome-shell go in the 200-350% range for me, in case that helps someone. Check for something using a camera.



  1. Your background,
  2. Your theme,
  3. If you're running Google Cloud SDK.

Change all 3 to see if it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.