0

I want to install the latest version of virtualbox on Ubuntu 16.04. I have followed a guide on adding a deb repo to the sources list. I've tried adding the yakkety repo and I've tried just leaving it blank. I even followed the official guide on virtualbox's website. But I keep getting this error:

The following packages have unmet dependencies:
 virtualbox-5.2 : Depends: libqt5core5a (>= 5.7.0) but 5.5.1+dfsg-16ubuntu7.5 is to be installed
                  Depends: libqt5widgets5 (>= 5.7.0) but 5.5.1+dfsg-16ubuntu7.5 is to be installed
                  Depends: libqt5x11extras5 (>= 5.6.0) but 5.5.1-3build1 is to be installed
                  Depends: libvpx4 (>= 1.6.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

Can someone help me out?

  • 1
    ok i figured it out. i went into my sources.list.d and edited out the virtualbox one's that had nothing to do with my version of ubuntu (16.04 in this case) And that fixed and now it's installed for me just fine – VeganTechnology Dec 25 '17 at 23:26
  • 1
    Please add that as an answer below (with a few more details), then wait a bit and click the checkmark next to the answer to mark the question solved. – Chai T. Rex Dec 26 '17 at 1:21
1

While trying to achieve this I had added repositories for different Ubuntu versions and that was causing the package conflicts. I went into my sources.list.d and removed the repositories for VirtualBox that were not for my version of Ubuntu (16.04).

That fixed my problem and now it's installed for me just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.