2

I installed Ubuntu 17.10 dual boot with Windows10 on my Dell XPS 15-9560 laptop.

I followed the instructions listed here: Ubuntu linux on Dell XPS 15 (9560)

After installation, I'm unable to shut down the system in Ubuntu. The computer displays this error message:

enter image description here

And refuses to shutdown.

  • Just to confirm - based on those instructions you are using the binary nVidia driver and not the default nouveau one? – user367250 Dec 25 '17 at 21:55
  • Hi Oliver, I am using the default nouveau one. Thanks – PPR Dec 25 '17 at 22:56
  • @OliverOberdorf: Following the instruction, I installed the binary nVidia driver. The problem persists with, see the screen grab for details: link. Thanks – PPR Dec 25 '17 at 23:26
  • hmm - do you have any network mounts in your fstab? It seems like that can cause issues too. See comment #72 in this thread bugs.launchpad.net/ubuntu/+source/linux/+bug/1530405/comments/… – user367250 Dec 25 '17 at 23:42
  • full bug for reference is bugs.launchpad.net/ubuntu/+source/linux/+bug/1530405 – user367250 Dec 25 '17 at 23:43
0

Since you are using the nouveau one, you might find this thread useful. The original post is a startup error, but the 2nd answer mentions your exact shutdown error and also solved it with the nVidia binary drivers.

NMI watchdog: BUG: soft lockup - CPU#2 stuck for 23s! [plymouthd:305]

You may need to blacklist or remove the nouveau drivers. You can do that with the appropriate portion from this post, adding it in /etc/modprobe.d/

Install Nvidia driver instead of nouveau

For example, I have:

/etc/modprobe.d/nvidia-384_hybrid.conf:blacklist nouveau
/etc/modprobe.d/nvidia-384_hybrid.conf:blacklist lbm-nouveau
/etc/modprobe.d/nvidia-384_hybrid.conf:alias nouveau off
/etc/modprobe.d/nvidia-384_hybrid.conf:alias lbm-nouveau off
| improve this answer | |
0

I had the same issue with Ubuntu 17.10 on Dell XPS 15 9560. The problem seems to be with the grub options and video driver. I manage to fix the issue by following instructions on the post https://connorkuehl.github.io/dell-inspiron-7559-linux-guide/index.html. In my case I did install the version nvidia-390 instead of nvidia-367

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.