Until 17.10 I mostly used Unity and never had this issue (I had GNOME installed and seldom used it). But since the upgrade I switched to GNOME, where the shortcut works and I find it better because it cycles through sources in the recently used order.

After a few months I decided to reinstall Ubuntu because it was too laggy, so the Unity session I have now was installed manually later. Then I noticed that it was GNOME especially that was too laggy on my 4GB RAM laptop, so I moved back to Unity which is much more fluid.

Here comes the issue, pressing Super+Space doesn't switch the input sources, and the weirdest thing is that Shift+Super+Space shows and horizontal switcher for English and French, instead of the vertical drop-down switcher from the panel where I don't even have an English source (I have French, Japanese and Belgian sources).

Note : I noticed that other shortcuts that use the Super key don't work as well as the other shortcuts : i.e. Super+E which I set to open nautilus as root only works when I press Super then E then release E and finally release Super. I don't remember having a 'release order' before, could it be related to the issue ?

Note 2 : I know I can bind another shortcut for this task (and it works), but I find the default one pretty good and I don't like this Super key malfunction.


About the input sources showed when I do Shift+Super+Space (English and French), I found that they are the same as in Fcitx Configuration (which key binding is set to Ctrl+Space) and as in IBus Preferences (which key binding was also set to Super+Space, but I set it to something else to test, however Super+Space still does not work).

  • Please show what the command gsettings get org.gnome.desktop.wm.keybindings switch-input-source outputs. Dec 24, 2017 at 0:57
  • Show us also what the command gsettings get org.gnome.desktop.input-sources sources outputs. Dec 24, 2017 at 0:59
  • It outputs ['<Super>space'] (as expected I suppose)
    – N. Cornet
    Dec 24, 2017 at 1:01
  • Yes, it was expected. What about the other command I suggested? Dec 24, 2017 at 10:08
  • 1
    Everything looks normal AFAICT. Maybe it's a hardware issue. As a workaround, and as @N0rbert indicated, you may want to install gnome-tweak-tool and use Tweak to set an alternative shortcut for switching input sources. Dec 24, 2017 at 21:57

2 Answers 2


Ubuntu 17.10 solution:

  1. Run ibus-setup
  2. Disable shortcut for changing layouts (delete it).
  3. Set Super+Space shortcut in System Settings -> Keyboard.

It's a conflict between IBus and System Settings shortcuts.

  • 1
    No, as I said I changed it to something else and Super+Space still doesn't work (and if it was bound to IBus, I would see it since there is a "visual feedback" when switching IBus sources)
    – N. Cornet
    Jan 24, 2018 at 15:32
  • Works for me, but with annoying delay(( Jan 26, 2018 at 15:00
  • This works but it's still interfering with the Unity plugin - while changing input sources, the Dash menu or keyboard shortcuts popup occasionally display. I used ccsm to disable the Unity plugin's Super shortcut, which works around the issue, as I rarely use the dash.
    – rjh
    Feb 4, 2018 at 2:44

The shortcut was bound to something else and the other actions bound to Super+Space were not executed.

I was wondering why sushi wasn't working on nautilus when I noticed that what I wanted was gnome-sushi, so I uninstalled (and purged) sushi and now Super+Space allow me to switch between the IBus input sources.

As the IBus input sources are not the same as the ones I setted through the System Settings, I changed IBus key binding (can be done by typing ibus-setup in terminal).

I still don't know why the IBus (and the fcitx) input sources aren't the same as the ones in System Settings, but my problem is solved.

EDIT : I had this issue again, so it might not have been sushi (but maybe it was sushi first, and something else after that), but I have found a work-around which is to switch back to lightdm (which is fine to me since it is more continuous than gdm with Unity).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .