4

When I type sudo apt-get update I get the following message in the terminal

W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/google-chrome.list:3

How do I fix this?

0

1 Answer 1

7

Each warning message occurs when the package manager discovers a duplicate source.

To fix the problem, simply edit the source file and delete-or-disable one of the sources.

Let's deconstruct one sample line:

Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:52 and /etc/apt/sources.list.d/google-chrome.list:3

Now let's look at it again:

Target Packages (PATH) is configured multiple times in FILE_1:LINE_1 and FILE_2:LINE_2

In order to fix the source for PATH (main/binary-amd64/Packages, Google Chrome):

  • You can delete FILE_1:LINE_1 (/etc/apt/sources.list, Line #52)
  • Or you can delete FILE_2:LINE_2 (/etc/apt/sources.list.d/google-chrome.list, Line #3)

WARNING: DO NOT DELETE all of FILE_1 or FILE_2. Your system needs those files. Those are the files that tell your system where to get software upgrades from. NEVER DELETE the file /etc/apt/sources.list - it provides security upgrades.

0

Not the answer you're looking for? Browse other questions tagged .