1

I just installed Android Studio on Ubuntu 16.04 and I can't open it. When the welcome page of android studio opens I click on Start a new Android Studio project and it says Your Android SDK is missing, out of date or corrupted. I downloaded the last version of SDK Tools from android studio webpage and tried to add it to sdk manager but it says: Target folder is neither empty nor does it point to an existing SDK installation... I don't know what to do now..! :((

  • Have you tried adding SDKs from Android Studio's settings instead of downloading them from a website? – SurvivalMachine Dec 23 '17 at 20:41
  • Yes I tried that one too but it doesn't work – Mina Fa Dec 23 '17 at 21:00
3

I had the same problem and I solved it by following these steps:

  1. Go to android studio and then go to configure option on the bottom of the window.
  2. Go to 'project default' option in that option and click on project structure option.
  3. Change the SDK location to your sdk location. (If you get errors such as your location not a platforms you must go to your sdk location and make an empty folder and rename it to 'platforms'. Then you must repeat this steps.)

    Note:this error may arise when your sdk folder not a 'platforms' folder and you must make an empty folder and rename it to 'platforms'. platforms folder must be in the sdk folder.

For more information you can watch these videos:

  https://www.youtube.com/watch?v=3XiUavaRwt0
  https://www.youtube.com/watch?v=DuagOiwIbUk

1

The current direct link for SDK Tools package is (2018-12-31): https://dl.google.com/android/repository/sdk-tools-linux-4333796.zip. But, as others have already said in other responses to similar questions on SO, the best way is to let Android Studio handle the installation, because it will install other useful apps, too (emulator, platform tools, etc). In my case, I wasn't connected to the internet when I first started Android Studio, so I got stuck at the same error. After removing the ~/.AndroidStudio3.2 folder and a ./studio.sh restart, it asked me to download all the necessary apps (note: the dowload has ~1GB!) and then Android Studio started flawlessly!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.