0

I am trying to install Steam on my 64-bit Ubuntu system (ARM64), but I am running into problems with the 32-bit libraries.

I have installed the .deb package from their website. The problem is the following error when running the Steam Launcher for the first time:

You are missing the following 32-bit libraries, and Steam may not run:
libc.so.6

After reading lots of similar questions, I think I have found the underlying problem. It is the following, when using auto-update:

Reading package lists... Done
E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/xenial/main/binary-i386/Packages  404  Not Found [IP: 91.189.88.150 80]
E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/xenial-security/restricted/binary-i386/Packages  404  Not Found [IP: 91.189.88.150 80]
E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/xenial-updates/restricted/binary-i386/Packages  404  Not Found [IP: 91.189.88.150 80]
E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/xenial-backports/main/binary-i386/Packages  404  Not Found [IP: 91.189.88.150 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.

When trying to install the libraries like this:

sudo apt-get install wget gdebi libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libc6:i386

I get the following:

Reading state information... Done
E: Unable to locate package libgl1-mesa-dri:i386
E: Unable to locate package libgl1-mesa-glx:i386
E: Unable to locate package libc6:i386

When I try to install them like this:

sudo apt-get install '^libc6.*'

I get the following:

libc6-powerpcspe-cross is already the newest version (2.23-0ubuntu3cross1).
libc6-ppc64-cross is already the newest version (2.23-0ubuntu3cross1).
libc6-ppc64-powerpc-cross is already the newest version (2.23-0ubuntu3cross1).
libc6-s390-s390x-cross is already the newest version (2.23-0ubuntu3cross1).
libc6-s390x-cross is already the newest version (2.23-0ubuntu3cross1).
libc6-sh4-cross is already the newest version (2.23-0ubuntu3cross1).
libc6-sparc-sparc64-cross is already the newest version (2.23-0ubuntu3cross1).
libc6-sparc64-cross is already the newest version (2.23-0ubuntu3cross1).
libc6.1-alpha-cross is already the newest version (2.23-0ubuntu3cross1).
## And so on, this is a huge list...

When I try to run this:

sudo apt-get install steam

I get this output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
steam:i386 is already the newest version (1.0.0.54).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I am running Ubuntu Xenial 16.04. Can someone help me towards a solution here?

Thank you very much!

  • Have you tried apt-get install steam? Or perhaps apt-get -f install? – dobey Dec 23 '17 at 14:16
  • Have you enabled multi-arch support? – hexman Dec 23 '17 at 14:49
  • @hexman Multi-arch support is enabled, and @dobey ` apt-get install steam` does not seem to work (see my original post). – Esli Dec 23 '17 at 15:59
  • I have an ARM64 processor. Could that have anything to do with it? – Esli Dec 23 '17 at 16:10
  • 3
    @Esli You're trying to install an i386 (32bit) application on an ARM arch, of course it's not going to work even with i386 libraries. Afaik, Steam doesn't support ARM yet but I could be wrong. Either way edit your question so people can tell you're trying to run it on an ARM64 processor not amd64 as most people would assume. – hexman Dec 23 '17 at 17:19