0

I use Caps Lock to change keyboard input language. After upgrade to 17.10 with gnome-shell v.3.26.2-0ubuntu0.1 a popup thingie shows up in the center of the screen with available layouts to choose everytime I press Caps Lock.

But that annoying thing is taking up input focus and turns off after a couple seconds only. Not linked with input method key setting at all, i.e. I can change layout with another Alt+Shift combo and that thing doesn't show up.

UPD: That thing only shows up on single-key switch modifier (i.e. CapsLock). If I press Alt+CapsLock for example (combo not assigned to anything) - it doesn't show.

Anyone knows what is that and how do I disable that?

  • Try to tap the key instead of pressing it. – Gunnar Hjalmarsson Dec 23 '17 at 12:53
  • This is what I do. Point is to get rid of that thing. – Andrey Ryazantsev Dec 24 '17 at 10:39
0

Let me make the previous answer more precise. Install gnome tweak tool: $ sudo apt install gnome-tweak-tool Open it, then Keyboard & Mouse -> Additional Layout Options -> Switching to another layout choose the option Caps Lock. Now gnome-tweak-tool can be closed.

To reset the switch in the desktop options run Settings dialog, Devices -> Keyboard -> Switch to the next input source. I tried to set the option both to Disabled and to Default, both works.

0

Resolved that issue on my own. I set input language switch solely to CapsLock key without other combinations (using gnome tweak tool). Not sure if it affects results, but I also reset next/prev input source keys to defaults (Super+Space) in keyboard settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.