5

I just installed Ubuntu 17.10 and my scroll bars are WAY to narrow. I can barely grab them with my mouse. The scroll bar in LibreOffice and Firefox is so small I can barely grab it.

I have searched Google for hours trying to find a solution to this, with no luck.

Can someone please tell me how to change the width so that they're actually usable? I'm fairly new to Linux and the less complicated method, the better.

click here for screenshot

1
  • I've added a screenshot to the OP. I'm not sure which theme I'm running, I just downloaded and installed Ubuntu 17.10 from the Ubuntu website. If you look at the screenshot you'll see how skinny the scroll bar is. It's that way whether I'm in a libre document, firefox, or any other window that has the scroll bar. I can barely grab it to scroll. Dec 22, 2017 at 23:36

2 Answers 2

1

As I previously recommended in the answer to similar question you may try to remove overlay scrollbars and change CSS properties:

#Step 1
echo "export GTK_OVERLAY_SCROLLING=0" >> ~/.profile

#Step 2
mkdir -p ~/.config/gtk-3.0
cat <<EOF > ~/.config/gtk-3.0/gtk.css
/* Adding the buttons on the edges (if you don't need them, skip the next 4 lines)
 */

.scrollbar {
  -GtkScrollbar-has-backward-stepper: 1;
  -GtkScrollbar-has-forward-stepper: 1;
}

/* Scrollbar trough squeezes when cursor hovers over it. Disabling that
 */

.scrollbar.vertical:hover:dir(ltr),
.scrollbar.vertical.dragging:dir(ltr) {
    margin-left: 0px;
}

.scrollbar.vertical:hover:dir(rtl),
.scrollbar.vertical.dragging:dir(rtl) {
    margin-right: 0px;
}

.scrollbar.horizontal:hover,
.scrollbar.horizontal.dragging,
.scrollbar.horizontal.slider:hover,
.scrollbar.horizontal.slider.dragging {
    margin-top: 0px;
}

/* Slider widens to fill the scrollbar when cursor hovers over it. Making it permanent
 */

.scrollbar.slider.vertical:dir(ltr):not(:hover):not(.dragging) {
    margin-left: 0px;
}

.scrollbar.slider.vertical:dir(rtl):not(:hover):not(.dragging) {
    margin-right: 0px;
}

.scrollbar.slider.horizontal:not(:hover):not(.dragging) {
    margin-top: 0px;
}

EOF

#Step 3
cat <<EOF > ~/.config/gtk-3.0/settings.ini
[Settings]
gtk-color-scheme="tooltip_bg_color:#ffffaf\ntooltip_fg_color:#000000"
gtk-application-prefer-dark-theme=0

gtk-primary-button-warps-slider = false

EOF

#Step 4
sudo apt-get purge overlay-scrollbar overlay-scrollbar-gtk2 

It works at least on 16.04 LTS with MATE DE.

2
  • In gtc-3.0/settings.ini The lines about gtk-color-scheme & gtk-application-prefer... don't affect the scrollbar do they?
    – Xen2050
    Dec 23, 2017 at 23:30
  • @Xen2050 it is yellow tooltip, which I like. Free bonus :)
    – N0rbert
    Dec 24, 2017 at 10:40
-1

Check the settings on your TV/Monitor it could be the same problem I had. Please go here>> How do I fix overscan on my HDMI HDTV? << Worked for me.

1
  • This is only a link, and they disappear frequently. What's the real answer?
    – Xen2050
    Dec 23, 2017 at 23:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.