0

I had 2 Windows 7 64-bit and Ubuntu17.04 installed on my Lenovo Y50-70 laptop. I decided to reinstall them. I formatted all disks and installed Windows 7, leaving about 50GB free space for Ubuntu 17.10. I installed Ubuntu (I chose to install with Windows 7 option), rebooted and got stuck with this black screen:

enter image description here

It didn't disappear, so I decided to push the power button. Then it rebooted and showed this message:

enter image description here

Then GRUB turned on and there was no option to run Windows 7, only Ubuntu. I tried to reinstall Windows 7, but every time I got the message that there is no driver (I started the setup, changed the USB port, etc. but nothing helped). Then I reinstalled Ubuntu and now every time I start the computer I have messages like in the second image. I tried to set the BIOS preferences to default, or just change the EFI mode for USB boot, but for some reason the settings aren't saved. When I try to run Windows, it gives me the second error message screen, but Ubuntu 16.04 is installing without any problems, except one, that at the end of the installation I'm getting the first error message screen.

  • For now do not use 17.10 Ubuntu 17.10 "corrupting" BIOS - many LENOVO laptops models Intel SPI & kernel issue Also some Acer bugs.launchpad.net/ubuntu/+source/linux/+bug/1734147 Was system configurated for UEFI. Default installer for Windows 7 is BIOS only, you have to reconfigure it on flash drive to make it UEFI bootable. – oldfred Dec 22 '17 at 21:28
  • @oldfred, but how can I reconfigure it to make it bootable? – koshachok Dec 22 '17 at 21:35
0

I installed Ubuntu 17.10 - it was my mistake. By the way here you can find some example of solution: https://forums.lenovo.com/t5/Lenovo-P-Y-and-Z-series/Y50-70-BIOS-Can-t-Save-Settings-Or-Exit/m-p/3853208#M157885

0

I too have the second image issue. I showed it to my college's IT department, They didn't figure out this problem. I have this problem form few month back. Till now I must have booted alot of times. This message shows up every time. Still i cant resolve this, but OS works fine.

And I think you have installed 17.10 that's why in some lenovo laptop the BIOS setting donot save. You can check it here about this problem. Ubuntu 17.10 Breaks the BIOS on Some Lenovo Laptops

Due to this issue you can't do dual boot. So i reccomend to use Ubuntu 16 for dual boot.

And, I don't think you can solve that second image problem without Updating BIOS with windows OS. I dont think you can update your BIOS with Ubuntu.

  • Yeah, i know it :). I resolved it by installing arch as OS and installing VM with windows7 on it. I have a possibility to install 2 OSs, but when I'm installing grub, for some reason I'm removing Windows interface (I have only black screen, but there are sound, thats how can i detect, that windows is starting). – koshachok Dec 26 '17 at 11:37
  • I think you need to disable fast boot while installing OS. And thanks for the idea to resolve this issue. – user588672 Dec 26 '17 at 11:44
  • As fast boot do u mean installing system without choosing where would u like to install the system etc? – koshachok Dec 26 '17 at 12:27
  • I didnt get that, But i mean In BIOS setup there may be a option called Fast Boot if it is enabed and you install ubuntu for dual boot, you can never go back to windows. – user588672 Dec 26 '17 at 13:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.