1

I am a .net Developer who's currently moving to Linux world, I managed to install both Windows 10 and Ubuntu 16.04 on the same machine. I can access my windows partitions from Ubuntu which is great, but I have my own workspace for PHP development that I want to share between the two Operating Systems. I tried to create a virtual host on Apache2 for a folder resides on NTFS partition (which is my D:\ partition on windows) but when I open the browser and navigate to the virtual host address I get error number 403 permission denied from Apache.

It's obvious it's permission related issue. however I've set the ownership and the permissions from Ubuntu using the chown and chmod commands but still, I get the same error, which led me to believe its related to the fact that the folder belongs to windows and formatted in NTFS. I wonder if there is a way I can get this issue resolved. the reason I need to have my workspace shared between Windows and Ubuntu is that I use both OS's for development because I need more time learning Linux until I can move to It preeminently.

0

This is a common error you will encounter if you havent done the below :

reboot to you windows OS , and there do the following

1) Go to "power options" , which will come up when you right click on the battery icon

2) On your left , open either of these : -> choose what power button does -> choose what closing the lid does

3) you will see a link on top which says : -> (adminSymbol)"change settings that are currently unavailable"

4) remove all the ticks of , fast startup , sleeo , hibernate and lock ,

5) save the changes and reboot the system ,

6) and , check if you can access the windows directories from your ubuntu machine ! , i am sure you will be able to :) .

I hope this helped , this should solve your problem ,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.