I am installing spidermonkey on Ubuntu 11.10. When running ./configure I receive a dependency error that libnotify >= 0.4 is not met.

Located the package in Ubuntu as


So then I found out where it was installed.

renshaw@renshaw-TravelMate-5740G:~/spidermonkey$ dpkg -L gir1.2-notify-0.7

So then I have attempted to add this to PKG_CONFIG_PATH with

export PKG_CONFIG_PATH=/usr/lib/:/usr/lib/girepository-1.0/Notify-0.7.typelib

However I still receive the error.

configure: error: Library requirements (libnotify >= 0.4) not met;

How can I get ./configure to see libnotify as gir1.2-notify-0.7?

1 Answer 1


You need to install the *-dev packages if you need to compile something using that library.

In your case you need libnotify-dev. Install it (sudo apt install libnotify-dev) and run ./configure again.

  • For RHEL I got it from here: yum install http://mirror.centos.org/centos/7/os/x86_64/Packages/libnotify-devel-0.7.7-1.el7.x86_64.rpm
    – Noam Manos
    Commented Jun 24, 2018 at 13:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .