I recently built a barebones machine (shuttle SH67H3), installed Oneiric (64-bit) and everything was great (no wireless card but wired connection was fine).

Now our router has changed locations and I'm trying to get wireless to work. I purchased a TP-Link TL-WN722N because I saw this post and assumed it would be smooth sailing from the moment the wireless usb adapter arrived at my home. WRONG.

Has anyone had any experience setting this up? I've downloaded the compat-wireless-driver, compiled and run install (all successfully) but am unable to load it.

If there are any alternative devices that are known to work with my setup I would love to hear about them as well.


I've installed the linux backports modules successfully and rebooted several times. Still no wireless activity.

When I list the usb devices it can clearly see the wireless adapter (Bus 003 Device 003) plugged in:

user@ubuntu:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 003: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
Bus 001 Device 003: ID 192f:0416 Avago Technologies, Pte. 
Bus 001 Device 004: ID 413c:1003 Dell Computer Corp. Keyboard Hub
Bus 002 Device 003: ID 1058:1100 Western Digital Technologies, Inc. 
Bus 001 Device 005: ID 413c:2010 Dell Computer Corp. Keyboard
  • I have tried installing linux-backports-modules-cw-3.1-oneiric-generic but that did not work. The wireless network does not appear under the connection settings.

  • I tried wrapping the Windows XP driver following this post using the ndisgtk and ndiswrapper packages. All of the driver .inf files failed to load properly except the Windows XP version. The XP version loaded and even recognized the hardware. Still no wireless network options after several reboots and unplugs/replugs.

Are there any other setup steps that I am missing? After installing linux-backports-modules-cw-3.1-oneric-generic and rebooting should the wireless network just show up under the network settings? Is there anything else I can check at this point?

I'm willing to settle my loses and buy a different wifi adapter if I could be certain it would work with my setup. Anyone using 11.10 + usb wifi adapter?

  • the most known working driver i am aware of is the alfa bg usb card. it works for everything - injection, crypto, ap mode, standard, everything...it's just not an N card. Jan 26, 2012 at 22:18
  • I'm not sure what that means but I will try my best. I did find one post that suggested blacklisting the acer_wmi kernel module. Going to try this tonight as well.
    – bnjmn
    Jan 31, 2012 at 22:10
  • @OneZero Thanks for the help but I was still unsuccessful. I'm considering downgrading to 10.4 since I'm just getting started and it seems many people are having trouble with wireless adapters on 11.10
    – bnjmn
    Feb 7, 2012 at 15:05
  • use windows wireless driver utility ndiswrapper-utils , go to software center and try search windows wireless driver , hope this will work
    – One Zero
    Feb 7, 2012 at 16:08

3 Answers 3


Run lsusb to make sure the machine recognizes the adapter and confirm the chipset. You should see the following on one of the lines:

0cf3:9271 Atheros Communications, Inc.

The machine needs both the proper firmware and driver to utilize the adapter. Get the htc_9271.fm firmware file from here (I used version 1.3, get whatever is most recent) and copy it to the lib/firmware/ directory. Next, download the compat-wireless drivers here. Unarchive it and build the ath9k_htc driver by running the following commands in order:

tar xvf compat-wireless-
cd compat-wireless-
./scripts/driver-select ath9k_htc
sudo make install 

Load the driver

sudo modprobe ath9k_htc

If this does not work (you should now see wireless networks available), try unplugging the adapter and reinserting it. Also, a reboot might help but could require reloading the driver with modprobe again.

  • I'm trying this, but I get pastie.org/3550667. Any idea?
    – umpirsky
    Mar 8, 2012 at 20:03
  • Fixed that by getting compat-wireless-3.3-rc1-2.tar.bz2 from orbit-lab.org/kernel/compat-wireless-3.0-stable/v3.3 but wireless internet is still slow. Any idea?
    – umpirsky
    Mar 8, 2012 at 21:02
  • Not sure about performance tweaks. Once I got it running, speeds were appropriate for my router. Feel free to update with any tips.
    – bnjmn
    Mar 16, 2012 at 16:36
  • You could accept your own answer just to show that it's working and it's the correct answer
    – rslite
    Jun 9, 2012 at 1:44

If you haveng trouble using BT in you VM, Do not use VM, see this link https://www.virtualbox.org/ticket/9511?cversion=0&cnum_hist=2

just boot BT in your computer if you are using cd or usb, and then go to Wicd Network manager > Preferences > General Setting > on Wireless Interface type "wlan0" refresh Wicd. hope this will help you


I had the same problem...bought the wifi usb card, dead as a doorknob in ubuntu. Without further details, I took the wifi card to a windows 7 laptop, and installed in there with the included mini cd.

Brought it back to my ubuntu laptop, and lo and behold! Green light, network manager sees it, etc., etc. A lot simpler and faster solution, if unorthodox.

  • @aaron Do you have any idea why this might have worked? Does it involve firmware being installed to the card itself, when it's in the Windows system? Did you take these actions deliberately with the knowledge they might work, or did you discover this method accidentally? If the latter, is it possible some other factor made it work on Ubuntu the second time, other than being used in Windows first? While I do think this answer is okay right now, I think it would be better if you were to edit it to add more information about why you believe this technique works. Aug 9, 2014 at 12:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .