1

On Ubuntu 16.04, I ran this command on terminal:

sudo rm -rf ~/.config

After this top taskbar is removed, and I can't go anywhere. So, I reboot system from the terminal which was already opened.

After reboot, system boots fine. I have noticed that chrome was removed and there is no wifi indicator on taskbar.

So, I reinstall chrome and ran few commands like

killall unity-panel-service
sudo service network-manager restart
sudo apt-get install indicator-applet indicator-network

to get it back, but nothing.. except I installed chrome again and all logins and history was not removed. (I wonder why those didn't removed with chrome)

And now I'm unable to connect to any other wifi network from System Settings > Network > Wireless.

Solution I need is, wifi indicator back and I should able to connect to other network as I was able to do before..

  • You might want to have a look at safe-rm package, it helps greatly preventing accidental deletions like that. – dessert Dec 21 '17 at 10:45
  • @dessert Solution I need is, wifi indicator back and I should able to connect to other network as I was able to do before.. – luser Dec 21 '17 at 11:03
  • Ubuntu 16.04 LTS – luser Dec 21 '17 at 11:10
  • What was your intent when you deleted .config? Were you intending to loose desktop configurations and start over? You figured out the hard way you can't simply delete this directory. – jdwolf Dec 21 '17 at 11:13
  • 1
    @luser: You can edit your question to include the information which was asked for. Please do so. – Videonauth Dec 21 '17 at 12:59
1

Because files in /home aren't managed by the package manager reinstalling them won't do anything.

.config contains a lot of files related to the users desktop configuration and application configurations.

.config primarily is configuration for applications where data (like for example your emails if you're using evolution) are stored in .local.

Applications rely on config files it created in .config to work as expected. Some applications may recreate the configs in .config if they are missing but others probably won't if they still see files in .local.

While deleting .config shouldn't break anything it appears to with unity. The configurations are likely not in a default state but a zeroed state.

The culprit seems to be that the indicator applets are suppose to be in Startup Applications but no longer are. Search for Startup Applications in settings and add

| improve this answer | |
  • Add example please: like "name", "Command", "Comment" – luser Dec 21 '17 at 12:12
1

I have figure out the solution from another thread (https://askubuntu.com/a/530958/773953), which helped me, +1 to them.

SOLUTION:

[ STEP 1 ]

sudo apt install network-manager-gnome

Install network manager, which might have removed with .config directory like chrome.

nm-applet

Run Applet, network indicator should popup by now.

If you can notice, exiting terminal will remove the indicator. So, you have to add it in Startup Applications.

[ STEP 2 ]

Search and run "Startup Applications" in Ubuntu search.

Startup Applications

Click on Add and write nm-applet in Command field, and Add it.

Startup Apps Dialog Popup

Write nm-applet in Command

Close the dialog popup and reboot you Ubuntu. And it should always be on there(top bar) for YOU.

| improve this answer | |
0

Try reinstalling network-manager

sudo apt-get install network-manager # if it was removed

or install the indicator applet

sudo apt-get install indicator-applet indicator-network
| improve this answer | |
  • reinstalling network-manager will automatically pop indicator or I have to reboot after its complete. – luser Dec 21 '17 at 11:22
  • And I have already tried install indicator applet before, nothing. – luser Dec 21 '17 at 11:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.