0

I recently changed my entire machine and i just swapped my ssd in the new machine. grub2 works and shows my options, when i choose (k)ubuntu, it will end up in an empty black screen, however, when i do Ctrl+ALT+[F1-F6] all shells are running. when i issue sudo init 5 or sudo systemctl isolate graphical.target the login manager successfully shows up and everything works, upstart works as well. I did a update-grub, but this doesn't at all look like a grub issue. i don't know how to fix the normal process so i wont have to do this every time.

Please let me know if i can provide more info.

4
  • What does this command show you from one of the terminals logged in as root (or using sudo)? systemctl get-default
    – TopHat
    Dec 20, 2017 at 22:11
  • Oh, also, systemctl list-jobs should show if it's waiting on some particular service causing a hang.
    – TopHat
    Dec 20, 2017 at 22:23
  • so, ... get-default, it actually shows graphical.target! the problem is , it actually works when i do 'init 5' or 'systemctl isolate graphi .." Dec 20, 2017 at 22:31
  • To confirm that this is indeed a graphics issue, you might want to set nomodeset in grub (e.g., GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"). This will prevent mode switching into your video chipset driver.
    – richbl
    Dec 21, 2017 at 3:03

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.