3

I'm on 16.04 running the i3 window manager.

I recently installed the inconsolata font using:

$ sudo apt-get install fonts-inconsolata

I updated the cache:

$ sudo fc-cache -fv

The font appears to be installed:

$ fc-list | grep -i inconsol
/usr/share/fonts/truetype/inconsolata/Inconsolata.otf: Inconsolata:style=Medium

Yet, when I try to use in my terminal (by trying to set the font from the terminal's menu options Edit and then "Profile Preferences", it is not listed among the available fonts.

I've also launched the Unity tweak tool using:

$ unity-tweak-tool

… and I was able to set "inconsolata medium" as the "monospace font" but nothing changed. It's not really clear to me how the monospace font configured in the Unity tweak tool relates to the font used in the terminal, but like I said, nothing changed.

Finally, as another data point, here's what I see under /usr/share/fonts:

$ find /usr/share/fonts | grep -i  incons
/usr/share/fonts/truetype/inconsolata
/usr/share/fonts/truetype/inconsolata/Inconsolata.otf

update

Based on a suggestion, I got the .ttf version from Google fonts and installed it in my system (and updated the fonts cache too). So now I see:

$ find /usr/share/fonts | grep -i incons
/usr/share/fonts/truetype/inconsolata
/usr/share/fonts/truetype/inconsolata/Inconsolata.otf
/usr/share/fonts/truetype/inconsolata/Inconsolata-Regular.ttf
/usr/share/fonts/truetype/inconsolata/Inconsolata-Bold.ttf

… and:

$ fc-list | grep -i incons
/usr/share/fonts/truetype/inconsolata/Inconsolata-Bold.ttf: Inconsolata:style=Bold
/usr/share/fonts/truetype/inconsolata/Inconsolata-Regular.ttf: Inconsolata:style=Regular
/usr/share/fonts/truetype/inconsolata/Inconsolata.otf: Inconsolata:style=Medium

The situation remains the same: I can't select "inconsolata" in my terminal's profile preferences.

  • Did you close and restart the terminal window? – chaskes Dec 20 '17 at 16:55
  • @chaskes yes I did. – Marcus Junius Brutus Dec 20 '17 at 16:57
  • Possibly you need to run fc-cache as yourself also, i.e. without sudo. – Gunnar Hjalmarsson Dec 20 '17 at 17:49
  • @GunnarHjalmarsson tried that, no luck. – Marcus Junius Brutus Dec 20 '17 at 18:23
  • 1
    Did you ever solve this? I am having the same issue on fresh installs of Ubuntu 18 on multiple different machines... – Bill May 10 '18 at 23:42
0

Inconsolata identifies itself as a "Decorative" font, instead of "Monospace". I am opening an issue on GitHub. In the meantime, you can edit the files in FontForge. (Element | Font Info | OS/2 | PFM Family)

FontForge settings for Inconsolata

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.