4

I reinstalled Ubuntu 17.10 (amd64) desktop 2 days ago, preserving all of my home directory data. No problem there.

Since the re-installation, I have noticed that pressing the left Alt key "steals" the focus from whatever application that I am running. I tried it in VSCode, Discord, and the GUI version of Emacs 25, and in all cases, the focus moves from away from the application.

I'm not sure if GNOME shell is trying to invoke the HUD, but I understand that it was removed with Unity in 17.10.

I checked my GNOME keyboard bindings in the settings, and Alt alone is not assigned to anything.

The behavior is very annoying, since I have several commands in VSCode that start with Alt, and none of the work now.

Is there any way to disable this behavior or assign some other key?

Update: It seems that the Alt key triggers the application's top menu in GNOME. I'm still looking for some way to change the bound key.

1 Answer 1

1

Hah! I found it.

I used the Gnome Tweak tool to disable the top bar menu and have each application display its own. (Top Bar > Application Menu).

Now the Alt key works as it did before.

1
  • Got the same issue, but couldn't find that option inside Tweaks using ubuntu, lmk if you find any other solution! Commented Nov 29, 2021 at 14:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .