[UBUNTU 16.04 LTS]

I've downloaded the Mega .deb and tried to install with:

sudo dpkg -i mega.deb

Then it throws this error:

Selecting previously unselected package megasync.
(Reading database ... 204976 files and directories currently installed.)
Preparing to unpack megasync-xUbuntu_16.10_amd64.deb ...
Unpacking megasync (3.5.3-2.1) ...
dpkg: dependency problems prevent configuration of megasync:
 megasync depends on libcrypto++6; however:
  Package libcrypto++6 is not installed.
 megasync depends on libqt5core5a (>= 5.6.0~beta); however:
  Version of libqt5core5a:amd64 on system is 5.5.1+dfsg-16ubuntu7.5.
 megasync depends on libqt5svg5 (>= 5.6.0~beta); however:
  Version of libqt5svg5:amd64 on system is 5.5.1-2build1.

dpkg: error processing package megasync (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.22-1ubuntu5.1) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Errors were encountered while processing:
 megasync

Then I tried:

sudo apt -f install to try to fix these missing dependencies and got this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  megasync
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 8.368 kB disk space will be freed.
Do you want to continue? [Y/n]

How can I make it fix the dependencies and not remove megasync?

Also tried sudo apt -y install ./megasync-xUbuntu_16.10_amd64.deb and got:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'megasync' instead of './megasync-xUbuntu_16.10_amd64.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 megasync : Depends: libcrypto++6 but it is not installable
            Depends: libqt5core5a (>= 5.6.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is to be installed
            Depends: libqt5svg5 (>= 5.6.0~beta) but 5.5.1-2build1 is to be installed
E: Unable to correct problems, you have held broken packages.
up vote 3 down vote accepted

You can simply double click the file via GUI after you have made it executable. This is the fastest and hassle free option you can choose, it lets the system handle the dependencies. If you insist on GUI solution use gdebi for installing which does the same. So in your situation, let sudo apt install -f remove it and then do the following.

# get the right package for your Ubuntu version 16.04 if this step fails 
# because you not have 'wget' installed do 'sudo apt install wget' and retry
wget https://mega.nz/linux/MEGAsync/xUbuntu_16.04/amd64/megasync-xUbuntu_16.04_amd64.deb
#update the package archives
sudo apt update
#if the next step tells you that gdebi is already installed skip to the line after that
sudo apt install gdebi
# installing it with gdebi
sudo gdebi megasync-xUbuntu_16.04_amd64.deb

This should install all the necessary dependencies and the package itself.

  • 1
    @karel All I wonder is why he did not download the package for 16.04 directly? mega.nz/linux/MEGAsync/xUbuntu_16.04/amd64/… this one should be tailored to fit the packages in his version of Ubuntu. – Videonauth Dec 20 '17 at 12:17
  • 1
    You're right @Videonauth, that's the problem, I'm using 16.04 and I've downloaded the 16.10 .deb, thanks for poiting it out, please answer as a normal reply so I can set it as resolved :-) – s3voch7 Dec 20 '17 at 12:20

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.