2

I'm trying to install dependencies for Baldure's Gate 2 Enhanced Edition:

Here's what I did:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install libc6:i386 libasound2:i386 libasound2-data:i386 libasound2-plugins:i386 libjson-c2:i386 libopenal1:i386 libstdc++6:i386 libssl1.0.0:i386 libexpat1:i386 libx11-6:i386 libxau6:i386 libxcb1:i386 libxcursor1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxinerama1:i386 libxrandr2:i386 libxrender1:i386 libjson0:i386 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libasound2-data' instead of 'libasound2-data:i386'
E: Unable to locate package libjson-c2:i386
E: Unable to locate package libjson0:i386

I've looked in packages.ubuntu.com, these packages exist for previous versions, but not for 17.10... Any workarounds you may suggest are welcome.

2
  • It is not really possible to do this as the older packages are not in the standard repos. What you can do is to directly download the packages from the package site and dpkg -I to install them.
    – hexman
    Dec 19 '17 at 16:08
  • Good to hear. Now make it an answer and accept it so others can benefit from your solution.
    – hexman
    Dec 21 '17 at 7:50
4

I've downloaded libjson packages manually from here: http://de.archive.ubuntu.com/ubuntu/pool/main/j/json-c/libjson-c2_0.11-4ubuntu2_i386.deb http://de.archive.ubuntu.com/ubuntu/pool/main/j/json-c/libjson0_0.11-4ubuntu2_i386.deb And installed them using Terminal:

sudo dpkg -i libjson-c2_0.11-4ubuntu2_i386.deb
sudo dpkg -i libjson0_0.11-4ubuntu2_i386.deb

Double clicking on them also does the trick :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.