0

A problem goes as follows:

  1. I start Ubuntu, login to xmonad.
  2. I run systemctl suspend.
  3. I wake the system pressing any key.
  4. Unlock the screen by typing password (keyboard works here).
  5. Ups... the keyboard is not responding, nothing.

The PC is running Ubuntu 16.04 with 4.4.0-103-generic kernel, has Xeon processor, I use Kinesis Advantage keyboard.

I can use mouse to copy&paste previously issued commands.

Important: it does not always happen.

Tried solutions / known similar:

  • Did you manage to fix this? – Binoy Babu Jun 8 '18 at 6:06
  • No. No workable fix, but i found a workaround. Apparently, the keyboard wakes when I switch a window focus, e.g. leaving a gedit open next to terminal I move the mouse to gedit and the keyboard wakes up. Now, I always lock/suspend with a two windows sharing a workspace. – Paweł Szczur Jun 8 '18 at 10:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.