2

I'd like to disable the touchpad, but keep the trackball (the little thing in the middle of the keyboard to move the cursor on the screen). On an other laptop (lenovo x220), I typed:

xinput set-prop `xinput list --id-only "SynPS/2 Synaptics TouchPad"` "Device Enabled" 0

and it worked great.

Now, on my new laptop, trouble is that xinput list gives:

~$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ DLL07A0:01 044E:120B                      id=11   [slave  pointer  (2)]
⎜   ↳ DualPoint Stick                           id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Integrated_Webcam_HD                      id=10   [slave  keyboard (3)]
    ↳ Intel HID events                          id=13   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=14   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=15   [slave  keyboard (3)]

I don't see any line mentioning touchpad or something like that (as it did on my x220 on which xinput list lists a TrackPoint and a TouchPad as two separate devices). If I disable device 12, the touchpad still works, but the trackball is disabled (which is exactly the opposite of my goal); disabling device 11 makes both touchpad and trackball disabled. Disabling both 11 and 12 is like disable 12 only. So, what should I do?

I have the xserver-xorg-input-synaptics package installed.

1

2 Answers 2

1

Now I've installed Ubuntu 18.04 and the trouble diseappeared by itself.

xinput set-prop `xinput list --id-only "DLL07A0:01 044E:120B"` "Device Enabled" 0

does exactly what I want.

1
  • Welcome to Ask Ubuntu! :-) Please don't forget to accept your own answer by clicking on the gray check mark in a few days if no other solutions are forthcoming.
    – Fabby
    Commented Aug 29, 2018 at 13:24
0

Look in the BIOS to see if disabling is available. It's how I did it on my x220 and t430. Dell may have a similar setting available.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .