0

This question already has an answer here:

This is a screenshot of gnome-center

I can see that the Software Center is installed, I can find it in Unity as well. But when I click on it, it doesn't seem to want to open. So, I tried the command line method, but that is not working either.

I cannot seem to open the Ubuntu Software Center by either the normal way or by using the command line software-center, which results in command not found.

What am I getting wrong here and how can I fix this?

marked as duplicate by karel, Fabby, Eric Carvalho, Zanna, David Foerster Dec 24 '17 at 0:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

The old Ubuntu Software Center software-center is not included in 17.04. The creators intended for you to use gnome-software instead.

  • Yes, I tried that too! It would just sit there looking all pretty but won't do a thing! Would I always have to type in a command line just to pop open a software center? – shikhar s Dec 19 '17 at 0:31
  • Did you upgrade to 17.04, or do a clean install? – Organic Marble Dec 19 '17 at 0:32
  • I upgraded from the previous version. If I remember correctly, software center used to open but only after several attempts and after a very long time. This has only been happening with 17.04 though. – shikhar s Dec 19 '17 at 0:33
  • I suspect it has something to do with the upgrade process. – Organic Marble Dec 19 '17 at 0:54
  • @shikhars did you clean up the GNOME software caches in your home directory? – Andrea Lazzarotto Dec 19 '17 at 1:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.