4

Yesterday I formatted a formerly shared hard drive(with Windows 10) into one exclusively for Ubuntu. Today, when booting up, I don't get to actually boot; when choosing Ubuntu from the grub menu, the screen simply goes grey, whereas normally it would go grey -> spinning ubuntu wheel -> login screen

I have no option to do anything. CTRL+ALT+F1 doesn't prompt the terminal, it is completely stuck.

What can I do?

2
  • Try this steps to show the bootup messages, and add the output (or at least the parts that may indicate an error and its prehistory) to your question.
    – Murphy
    Dec 18, 2017 at 11:56
  • Hi, it did nothing. Rebooting after those steps result in a grey screen still.
    – cbll
    Dec 18, 2017 at 17:58

4 Answers 4

1

In my case this was happening because there was an external monitor connected but not powered on. I unplugged the external monitor at which point the grey screen changed to the user login screen. I then had to reboot to get the mouse to work.

1
0

I have the same symptoms on 16.04.1 LTS, since yesterday.

Seems like you have no choice but to long-press the power button. Start the computer again, and it shouldshow the Grub menu.

On the "Ubuntu" line, press your keyboard's e key to edit the startup command. (In my experience every few times you do this, pressing e has no effect or just jumps to the last line. In that case just reboot and try again.)

In the editor that appeared, at the end of the linux line, add nomodeset (to waste less time go down to the next line then press your keyboard's left arrow).

Press F10 to reboot.

In my experience (limited to 5 times so far) it most often does not work the first time, so repeat the procedure until it works, it may take 4 times. Sometimes it just worked like this, sometimes I tried booting the recovery kernel (same linux kernel version) which got stuck then rebooted again then did the nomodeset trick again then it worked, not sure if that helped or not.

0

Just installed ubuntu mate 20.04.It gets stuck on a grey screen each time it boots.Found that if I leave it for 6 minutes it boots and works well.But 6 minutes to boot is frustrating.Noticed when I started to install it ran a full system check.Never seen this before.I wonder if this check is causing the hanging grey screen.

0

Try boot-repair, which has solved almost every problem I have faced booting up. Use a live َUbuntu USB to boot up your system into Ubuntu, connect to internet, open a terminal (ctrl-alt-t)and use these commands:

sudo add-apt-repository ppa:yannubuntu/boot-repair

sudo apt install boot-repair

when the inastallation is finished, open boot-repair, and try its options, mostly opening advanced options and reinstalling grub solves the problem. to do this you need to follow the steps exactly. You can read more here: https://help.ubuntu.com/community/Boot-Repair

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.