2

I am on Ubuntu 16.04 and I have installed MS Office 2010 over 2010 POL (v4.2.10 with Wine 2.22). The icons locked to the Unity Launcher are the correct MS Excel and Word icons, and both Excel and Word works fine when I click those icons.

However, both Excel and Word open in the Unity Launcher as the "Wine Windows Program Loader" (ie Wine Glass) icon and is grouped under it and not under Excel and Word icons.
Office under the Wine Glass icon

Here's the Excel .desktop file

[Desktop Entry]
Encoding=UTF-8
Name=Microsoft Excel 2010
Comment=PlayOnLinux
Type=Application
Exec=/usr/share/playonlinux/playonlinux --run "Microsoft Excel 2010" %F
Icon=/home/jd/.PlayOnLinux//icones/full_size/Microsoft Excel 2010
Name[fr_FR]=Microsoft Excel 2010
StartupWMClass=EXCEL.EXE
Categories=Office;Spreadsheet;

How can I change this behaviour to enable the Excel instances to be grouped under the Excel icon and the Word instances under the Word icon?

  • If you run xprop WM_CLASS in Terminal the mouse pointer will change into a crosshair. What's the output in Terminal if you place the crosshair over an Exel window and click? – pomsky Dec 18 '17 at 6:33
  • @pomsky - I get WM_CLASS(STRING) = "excel.exe", "Wine" – JayDin Dec 18 '17 at 7:32
  • Also I think you will have to escape the spaces in the name of the icon. – Bruni Dec 18 '17 at 8:41
2

If you run xprop WM_CLASS in Terminal the mouse pointer will change into a crosshair. Place the crosshair over an open Exel window and click.

You'll probably get an output like

WM_CLASS(STRING) = "excel.exe", "Wine"

Open the .desktop file associated with Excel and add (or modify) a

StartupWMClass=excel.exe 

line using the WM_CLASS(STRING) value for Excel (case sensitive) to the .desktop file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.