0

Edit: As per the response I received over at the GNS3 forums, looks like the IOU binary is 32-bit and therefore require 32-bit libraries.


I'm not sure if this is the appropriate place to ask but I hope someone here has some insight. I'm working on getting L2 IOU images up and running in GNS3 and I'm stuck at an issue. This is on a Ubuntu 16.04 machine. The images won't run because it says it's missing dependencies, specifically libcrypto.so.4.

I found this video that was supposed to be remedy however it wasn't based on Ubuntu. Following that, I issued the following commands to try and fix it.

tinyrick@tinyrick-PC:~$ find / -name 'libcrypto' 2> /dev/null

/home/tinyrick/Downloads/tor-browser_en-US/Browser/TorBrowser/Tor/libcrypto.so.1.0.0

/lib/x86_64-linux-gnu/libcrypto.so.1.0.0

tinyrick@tinyrick-PC:~$ sudo ln -s /lib/x86_64-linux-gnu/libcrypto.so.1.0.0 /lib/libcrypto.so.4

[sudo] password for tinyrick:

tinyrick@tinyrick-PC:~$ sudo ln -s /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0 /usr/lib/libcrypto.so.4

[sudo] password for tinyrick:

tinyrick@tinyrick-PC:~$

The video had used the /usr/ base directory so I tried that after leaving it out failed me.

In contiunation, I have removed both symbolic links to try and tried to use another suggested command to find the dependency. The following is the output of such....

tinyrick@tinyrick-PC:~$ sudo rm /usr/lib/libcrypto.so.4
[sudo] password for tinyrick:

tinyrick@tinyrick-PC:~$ sudo rm /lib/libcrypto.so.4

tinyrick@tinyrick-PC:~$ whereis libcrypto.so.4

libcrypto.so:

tinyrick@tinyrick-PC:~$

Any suggestions?

0

You have to use the 32bit version of the library, if you have a 64bit system this wont be downloaded.

To download the 32bit version go to https://www.codeweavers.com/support/wiki/diag/missinglibssl

Then you can create a symbolic link using:

find / -name '*libcrypto*' 2> /dev/null

Look for something like:

/lib/i386-linux-gnu/libcrypto.so.1.0.0

Then create the link:

sudo ln -s /lib/i386-linux-gnu/libcrypto.so.1.0.0 /usr/lib/libcrypto.so.4

Credit to the YouTube video that helped finding the solution: https://www.youtube.com/watch?v=chcHuF3nEoQ

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.