2

I bought a brand new Dell Inspiron 5567 - intel core i7-7500u cpu, with Ubuntu pre-installed. As you know, Dell does not provide any support for linux users and their information about linux is very basic. My question: how can I know if my Bios really needs update? If it does need update, how can I update it? Thanks.

  • You go into BIOS setup mode (press F2 at boot) and look at the version number? – AlexP Dec 17 '17 at 9:02
  • Do I press F2 right after I click the power button? Sorry, I'm asking because I've never done this before. Also, after I get the information how do I quit this screen? – Nermeen Hussein Dec 17 '17 at 9:04
  • 4
    dell.com/support/article/no/no/nobsdt1/sln284433/… - they do even provide you with a howto for how to update from an Ubuntu environment. – vidarlo Dec 17 '17 at 9:04
  • @vidarlo if you post that as an answer to the English version instaed of the Norwegian one and you ping me here, I'll come back and upvote. – Fabby Dec 17 '17 at 20:11
  • @Fabby Did't even realize they included language as a get id, so sorry for that. But posted as answer. – vidarlo Dec 17 '17 at 20:18
5

Dell do provide support, such as BIOS updates, even if you are running Linux. They do probably not provide application support though.

To know if you need an update, you have to check what version you are running (Press F2 during boot), and note down the version. Check this against the newest released version for your hardware on Dell's website.

Dell does indeed support updating the firmware from Ubuntu, as per their website, and they even have a separate page describing how to do it on Ubuntu.

| improve this answer | |
  • And upvoted! :-) – Fabby Dec 17 '17 at 20:21
  • A nice article with some methods worth trying - it should be pointed out that Dell makes many models of laptops and desktops, and only a very few are covered by these articles. – Charles Green Dec 17 '17 at 20:35
  • They do, but they provide USB method, which may require you to have access to a windows computer to make the USB drive, but not have Windows installed on the target device. – vidarlo Dec 17 '17 at 20:37
  • Yes, thanks a lot. Since you seem to know a lot about this issue can u please tell me what can go wrong in updating the BIOS? I did everything mentioned in the guide provided by Dell and I stopped at the very last step since I read about how "dangerous" this can be to the machine! After following the steps you kindly mentioned I found that my BIOS is quite old. Is it really important for me to update the BIOS or can I leave it as it is and live with the errors I'm getting? – Nermeen Hussein Dec 21 '17 at 8:13
  • UPDATE: I threw a bucket of ice on my head and went ahead with the update advised by Dell... The result: SUCCESS... thanks a lot Mr. vidarlo :-)) – Nermeen Hussein Dec 21 '17 at 9:15
1

I have a slightly older Dell laptop (15R-5521) which I believe that I purchased in 2012 - none of the update methods mentioned on the Dell pages have worked for this particular laptop, as the BIOS update programs produced for this unit (last in 2014) require a Windows environment. Dell support page

I was able, just recently, to update BIOS by a very long and torturous process:

  1. Download the BIOS update utility from the Dell product page, transfer this to a small USB
  2. Download a Windows 8 ISO
  3. Create a Virtual machine with Windows 8
  4. Purchase a 32 GB USB drive (larger could be used)
  5. Download a windows program WintoUSB - there are other programs which can perform this function, but all that I investigated require a running Windows system - in this case my VM was sufficient.
  6. Using WinToUSB and my running VM, burn a bootable Windows 8 USB
  7. Boot from the USB, insert the small USB and pretend I'm running a Windows system for a short while.

This was a really slow process: Win8 out of the box supports only USB 2, and since I was unwilling to pay for and license a version of Windows for this purpose, I did not allow either the VM or the Windows 8 USB to connect to the internet...

| improve this answer | |
  • My device is 2017 but I have cold feed updating the BIOS after I heard that it could terminally damage the device and turn it into nothing but a paper weight!! I have referred to this guide and stopped at the very last step: dell.com/support/article/us/en/04/sln171755/… – Nermeen Hussein Dec 21 '17 at 8:09
1

Dell uses the Linux Vendor Firmware Service (LVFS) to distribute UEFI updates to certain machines. To see if any are available and to apply them, follow the instructions on the fwupd GitHub page:

  • sudo fwupdmgr get-devices will display potentially-updateable devices
  • sudo fwupdmgr refresh will download metadata from LVFS
  • sudo fwupdmgr get-updates will display any available updates
  • sudo fwupdmgr update will download and apply any updates and will tell you whether a reboot is required
| improve this answer | |
  • Thanks a lot. I tried this and it gave me (after the 3rd command): No devices can be updated! So, I guess I'm good for now! – Nermeen Hussein Dec 21 '17 at 8:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.