29

I think I may have found the cause of my problems with connecting to wifi in Ubuntu 11.10.

I type this in Terminal:

$ rfkill list all
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
1: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
$ rfkill unblock all
$ 

If I am correct I must unblock all of those "yes", right? But nothing happens when I try to unblock. Am I typing the wrong command?


Typing sudo modprobe -r acer_wmi seem to have added another problem, now I can't even try to click on the "Enable wireless"-button as it has been grayed out and 1: acer-wireless: Wireless LAN does not show anymore in the rfkill list. Does anyone have any idea how to fix that?

EDIT: I rebooted and now it is not grayed out anymore and the rfkill list all shows as:

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no

The 0 is not Hard blocked anymore, but I guess 1: acer-wireless needs to be put off soft blocked somehow.

23

"Hard blocked" cannot be changed by software, look for a wifi toggle on your keyboard or edges of the laptop; the device can also be hard blocked if disabled in the bios.

"Soft blocked" means "blocked by software". A faulty driver or other kernel module can lead to connectivity loss.

Some methods to get WiFi working are described on help.ubuntu.com/

There is also a Launchpad question on this issue: answers.launchpad.net

| improve this answer | |
  • Thanks for the answer but none of that helped me. And typing "sudo modprobe -r acer_wmi" seem to have added another problem, now I can't even try to click on the "Enable wireless"-button as it has been grayed out and "1: acer-wireless: Wireless LAN" does not show anymore in the rfkill list. Does anyone have any idea how to fix that? EDIT: I rebooted and now it is not grayed out anymore and the rfkill list all shows as: 0: phy0: Wireless LAN Soft blocked: no Hard blocked: no 1: acer-wireless: Wireless LAN Soft blocked: yes Hard blocked: no The 0 is not Hard blocked anymore, but I guess 1 needs – user43703 Jan 26 '12 at 18:54
  • sudo modprobe acer_wmi is the opposite of sudo modprobe -r acer_wmi – Lekensteyn Jan 26 '12 at 18:57
  • THANK YOU! IVE BEEN LOOKING FOR THAT ANSWER FOR HOURS! YOU'VE JUST SOLVED MY PROBLEM! THANKS! – jaorizabal Mar 14 '12 at 22:37
  • FYI hard block also happens when the wifi is disabled in the bios. – Mike Pennington May 17 '14 at 18:55
  • Thanks for the answers after trying any things available on internet, i found this reply and noticed tiny button side of my laptop, i opened it and my WiFi start working, Thanks again! – Rizwan Yahya Jul 10 at 17:49
14

You can try a specify device like

 rfkill unblock bluetooth
| improve this answer | |
9

You have to blacklist the acer-wmi kernel module:

sudo nano /etc/modprobe.d/blacklist.conf

add blacklist acer_wmi as a new line at the bottom of this file.

then reboot.

Or if you like one-line:

echo blacklist acer-wmi | sudo tee -a /etc/modprobe.d/blacklist-acer-wmi.conf
| improve this answer | |
  • This worked for me. I am using an HP pavilion x360 Convertible 13.3. THANK YOU SO MUCH. – Dzhao Sep 8 '16 at 2:44
  • Worked with HP Notebook 17-x013na running Ubuntu 16.10. Many thanks. – Tim Rogers Mar 12 '17 at 17:41
  • After trying everthing this one worked for me on my Linux mint on my old Acer Aspire laptop. – Anil Maharjan Jan 10 at 20:43
2

For my working the solution described in https://ubuntuforums.org/showthread.php?t=1781350

My wifi card is Atheros and is working again.

sudo rmmod athk5
sudo rfkill unlock all
sudo modprobe ath5k

ubuntu 14.10

| improve this answer | |
  • I had to do first: rfkill list get the number from there and then do: sudo rfkill unblock 0 – Petar Vasilev Aug 17 '18 at 19:40
2

In my case it was disabled because of a switch which got triggered without me knowing.

On my Dell Laptop, I had to press Fn+F2 to get it started. It might even work with just F2 if the previous doesn't work. If it still doesn't work check for other possible triggers.

| improve this answer | |
1

I had similar issue with Lenovo e330. Out of nowhere wifi was hardware blocked and this model doesn't have any hardware switch. I've tried following things (none of them helped):

  • Fn + F9 combination (Lenovo key to switch wifi on/off)
  • rfkill unblock all
  • windows 10 installation + upgrading to latest Lenovo drivers
  • windows 10 + Lenovo Support diagnostics (on lenovo.com)
  • BIOS reset to default settings
  • enabling/disabling different BIOS settings (including wifi) back and forth

Then I removed the battery, and wifi started to work again!

| improve this answer | |
0

I had similar problems with HARD BLOCKED yes.

I found that I had to re-enable the wireless in the bios. I powered off the laptop. Powered it on. Press F2 for setup Go to Advanced, Onboard Devices and saw wireless was disabled. changed the setting. F10 and wahoo... yes... the blue light I was looking for returned... :)

| improve this answer | |
0

I'm using Ubuntu 12.04 on HP ProBook 4520s with Broadcom 4313 wireless. I have a "toggle wifi" button that is not recognized by Linux and does not work. However if I plug a network cable and turn the PC off then Ubuntu somehow forgets about the wifi and next time I boot the wireless is hard-blocked. The wifi button does not work so there's no way to unblock it :(

I found the following solution:

  • dual-boot to windows where the button works
  • enable wifi
  • reboot to linux

Hope this helps someone looking to fix a similar issue

| improve this answer | |
-1

This answer is for hp-probook with toggle wifi button and only ubuntu installed :

  1. Restart your computer and,
  2. just after restart press F2 to enter boot menu
  3. press F10 BIOS Setup
  4. Reset BIOS default
  5. Save changes and exit
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.