13

I followed How do I install Skype? to install Skype into my Linux. Chat is working fine but Audio, microphone, Camera is not working. When I checked in Skype under Tools > Audio Video Settings then I found that it's showing No device found.

4
  • Skype needs pulseaudio, and older versions of Lubuntu don't have it. sudo apt-get install pulseaudio. Dec 16, 2017 at 12:18
  • I have this problem -- almost: my camera is working, but not the audio. I get the system pings, but no sound at all via "Echo service", nor in the audio settings test. When I check the audio in Settings > Sound > Applications, "Skype" is showing with a Chromium icon. So I tried Jason David Hartzell's suggestion ... it the Chromium "Skype" extension (from www.skype.com) works perfectly. I'm running 18.04 pre-release, and Pulseaudio 11.1 is installed. Odd. It would still be good to have the "proper" client working properly, but at least I can use Skype on this machine now.
    – Dɑvïd
    Jan 12, 2018 at 9:43
  • I tried deb, snap and chromium plugin on Kubuntu 18.04.2 LTS but nothing worked. I have Pulseaudio 11.1 installed. Goodbye Skype! Apr 25, 2019 at 17:49
  • If KDE is used then you need to remove ~/.config/kmixrc file and restart Skype.
    – s4bba7
    Jun 16, 2020 at 23:02

3 Answers 3

7

I am using Ubuntu 18.04 and the editor Atom.

I found out that whenever I open Atom, Skype will not find any devices (no sound, no microphon, no camera).

However if I close Atom, and then start Skype, everything is shown. If I start Atom after Skype, everything will still work.

Very strange, but maybe it helps if you just close everything before starting Skype in Ubuntu.

enter image description here

2
  • 2
    I don't have Atom, but I do have Visual Studio Code and both use the same Electron base, so after following your steps Skype worked again! Jul 13, 2021 at 8:46
  • Same here, on Fedora 38 with VS Code running, Skype's audio settings only show a microphone "default device" and test call does not hear me. If I quit Skype and VS Code, then run Skype again, the Microphone list includes my "HD Webcam C525 Pro" and audio works. Running VS Code again does not break it, it still works. And weirdly, quitting Skype at that point and running it again, it still works.
    – Neek
    Feb 23 at 6:42
4

After a long investigation, I finally found the solution. Just remove the contents of the $HOME/.config/pulse/ (or rename the pulse to pulse.BAK to be safer).

I had old files created by the previous Linux installation. After removing those files Skype runs perfectly on every start.

2
  • This worked for my flatpak installation of Skype after closing most running applications.
    – Carolus
    Aug 24, 2021 at 9:55
  • This worked for me too. Flatpak install on Pop OS. I renamed the directory and restarted.
    – Brad
    Oct 23, 2021 at 23:10
3

I had the same problem and tried many of the 'old' solutions in the blog posts. There is a very simple solution. Download Google Chrome internet browser, go to 'extensions' type SKYPE, and download the first SKYPE extension. An icon will appear on the Chrome toolbar for skype - click it! sign in... And... you're done ;-)

2
  • Works for me - thanks! See further detail in my comment to OP.
    – Dɑvïd
    Jan 12, 2018 at 9:44
  • 2
    This is not a solution. The problem is with the native linux client and/or some interaction with audio/video in recent linux distribs. This solution suggests using something other than the native linux client. Apr 23, 2020 at 9:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .