0

I have a HP 2310ti 23" touch screen display, that's connected to USB. It's identified as the following:

ID 0408:3001 Quanta Computer, Inc. Optical Touch Screen

Problem description:

Since upgrading from Ubuntu 14 to 16.04 LTS (and from 3.x kernel to 4.x), the touch screen stops responding whenever the screen goes into standby. I have no screen saver as such, the screen just fades to black and the monitor goes into standby mode after a few minutes.

The computer has no keyboard or mouse attached, so there's no way to wake up the display, except remotely over VNC. If the screen is woken up over VNC, the touch screen works again like normal.

Having had the display for a long time, I know from experience that the touch screen is a separate device from the display. The touch screen normally registers touches even if the display isn't turned on from the power switch.

What I've tried so far:

Suspecting the problem might be a new USB power saving thing in the 4.x kernel, I tried to find solutions related to that.

The /sys/bus/usb/devices/usb2/2-1/2-1.4/power/control is set as "on" by default, and I tried setting the power/autosuspend to "-1", but there was no change.

What should I try next? Is there somewhere in particular I should look for somekind of debugging info, so I could see what happens when the screen goes into standby?

  • I don't know but you can try sudo powernap-action --disable usb_autosuspend sounds like the USB is being shut down powered off when it goes into idle . There is more info on this post – John Orion Dec 15 '17 at 20:26
  • I installed the powernap package and tried that command, but unfortunately it didn't help. – Solidcube Dec 15 '17 at 22:05
  • sorry .. that was the only thing I came up with .. maybe in the post some of the other commands may work for you – John Orion Dec 15 '17 at 23:56
0

It turns out the problem is with Gnome. When testing other window managers, the touch screen works as it should.

I tried Gnome classic, Openbox and Cairo-Dock gnome session, every single one woke up when touching the screen.

Using DConf I went through the settings, but was unable to find a setting that could affect the problem. So, in the end I solved the problem by switching the window manager.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.