0

I am trying to upgrade my haskell installation as, as far as I understand, it is a very old version.

This is what I have tried:

lpuggini@lpuggini-T3420:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.3 LTS
Release:    16.04
Codename:   xenial
lpuggini@lpuggini-T3420:~$ stack --version
Version 0.1.10.0 x86_64
lpuggini@lpuggini-T3420:~$ sudo apt upgrade haskell-stack
Reading package lists... Done
Building dependency tree       
Reading state information... Done
haskell-stack is already the newest version (0.1.10.0-1).
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
lpuggini@lpuggini-T3420:~$ stack upgrade
Fetched package index.                                                                                    
Populated index cache.    
Cabal file warning in /tmp/stack-upgrade1153/stack-1.6.1/stack.cabal: Ignoring unknown section type: custom-setup
Cabal file warning in /tmp/stack-upgrade1153/stack-1.6.1/stack.cabal: Ignoring unknown section type: custom-setup
Invalid package ID: "array-0.5.1.1 base-4.9.1.0 binary-0.8.3.0 bytestring-0.10.8.1"
lpuggini@lpuggini-T3420:~$ 
0

Ubuntu official repository has older version of the haskell-stack. Downlaod the latest one. First remove stack

sudo apt-get remove haskell-stack

then install using this which is the latest one

https://docs.haskellstack.org/en/stable/install_and_upgrade/#ubuntu

| improve this answer | |
0

I had the same error, so I removed the old version as described earlier:

sudo apt-get remove haskell-stack

then followed the "Linux (generic)" instructions at https://docs.haskellstack.org/en/stable/install_and_upgrade/#linux.

The wget command worked for me:

wget -qO- https://get.haskellstack.org/ | sh

I had installed gcc via sudo apt-get install gcc as part of the original failed attempt to upgrade stack.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.