1

This is a problem on my brand new Dell Latitude, equipped with Ubuntu 16.04.

Whenever I press a key, the touchpad scrolling stops working for a second or so. It is quite annoying, as I usually Alt-Tab and then immediately scroll, or type something on LibreOffice and then immediately scroll.

I thought this is related to "disabling touchpad while typing" feature, but I can use the touchpad for moving to cursor while typing, I simply can't scroll with two fingers.

I tried looking at my xinput props for the touchpad, but neither looked relevant. In particular, I tried to modify each property with "Timeout" in its name. I also couldn't find anything relevant in man synaptics.

After playing a little bit with "watch synclient", I figured out that each time I press a key, the property TouchpadOff switches from 0 to 2 for about a second, and this means that during that time "only tapping and scrolling is switched off". So it is probably not a bug, but rather, it is defined somewhere.

Can you help me find where it is defined, so I can reduce the time a little bit?

  • I was thinking the same thing .. it's a feature maybe in the laptop itself ... its probably set up that way so you don't have misclicks or movements when you are trying to type .. like on my laptop .. it drives me insane when I go to try to type something and the touchpad ends up clicking me in a different spot .. unfortunately I don't know where that setting would be but it might not be in Ubuntu because im using Ubuntu 16.04 and my touchpad doesn't do that ,,lol im the opposite of you .. I wish it did do that :D lol – John Orion Dec 15 '17 at 14:47
0

OK, I am not 100% sure, but I think I have solved the problem. I just ran syndaemon -i 0 -d with 0 replaced by some other numbers (1, 0.1, ...) and at first it didn't work, then it turned my touchpad off, and after turning it on again, the delay is now reasonable.

  • good for you .. hmm im going to make note of this and try it on my laptop and see if I can actually turn on this feature on it .. but it may be just too old – John Orion Dec 15 '17 at 14:49
  • Was this a permanent fix for you? I tried that and it didn't work. – snapcrack Jan 8 '18 at 5:06
  • It actually doesn't work for me, unfortunately. Playing with it a little bit seemed to work for a while, but eventually it just messed up everything, and after restart I could not do it again. – Bach Jan 8 '18 at 16:16

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.