0

I have 2 disks (system and data) in my computer. The data HDD has two partitions, one for media and one for private data (encrypted with veracrypt). The mount points are: /media/[myusername]/Media for media, and /media/veracrypt1 for my private data. So far so good.

The problem is, I replaced the the data HDD with a bigger one (same partitions), and now I cannot use my old mount point for the media partition. I can use /media/[myusername]/Media1, /media/[myusername]/Media2 and so on, but not /media/[myusername]/Media.

When i mount it into /media/[myusername]/Media, it is empty. The private data partition (mounted with veracrypt) works fine.

Does anyone know why and how to solve it?

Thanks in advance!

  • I had this issue once but I'll be darned if I can remember how I fixed it .. have you tried to delete the Media folder and then make it again? of course I mean the/media/[myusername]/Media folder – John Orion Dec 15 '17 at 12:01
  • yes, I deleted it, rebooted and tried again, but it doesn't work .... – zossima Dec 15 '17 at 12:12
  • are you mounting it through fstab or just manually mounting it? if mounting manually what is the error you get when you try to mount it to the mount point? – John Orion Dec 15 '17 at 12:13
  • i tried both - no errors, it seems to be a permission problem (I can access it as root), but only with the Media folder . I created it manually, changed the permissions and still cannot access it as user. Every other folder (Media1,..) works with user permissions – zossima Dec 15 '17 at 12:45
  • man I wish my memory was better .. this was the exact problem I had .. I could mount it but it was root accessible only ... I was using fstab to mount it .. it was something with the settings of fstab that caused it but .. again I cant for the life of me remember what the setting was or how I fixed it :( – John Orion Dec 15 '17 at 13:06
0

When mounting a NTFS drive using fstab you need to create the mount point and change permissions on the folder to 777 ..then add a line in your fstab like the following example:

UUID=<the drives uuid number> /path-to-mounting-point ntfs-3g defaults 0 0

UUID=F858A91658A8D522 /media/mountpoint ntfs-3g defaults 0 0

You can find the UUID by running sudo blkid

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.