This has been an issue for me with Unity since its release.
I'd like to make the the launcher auto-hide. Especially on Netbooks, where screens are small, the launcher is quite wide, making it difficult to properly display some websites and other apps. How can I configure the auto-hide behavior?

up vote 63 down vote accepted

11.04 & 11.10

The Unity launcher has an auto-hide option that is enabled by default. Lee's answer has the details. It has a few options:

  • Never - The launcher will never hide.
  • Autohide - The launcher will hide automatically based on time.
  • Dodge Windows - The launcher will hide when a window would overlay it.
  • Dodge Active Window - The launcher will hide only when an active window would overlay it.

This question has information on how to configure the different modes of Unity:

  • This doesn't seem to exist on 14.04. – jcora Jun 10 '14 at 20:34
  • @jzc This is the answer you want: askubuntu.com/a/106673/235 – Jorge Castro Jun 10 '14 at 20:47
  • I was looking for the additional options, Dodge Windows and Dodge Active Window. The answer you linked states: Unlike previous versions of Ubuntu, the dodge windows option has been removed due to User testing that showed that this form of autohiding caused confusion. (From the answer) – jcora Jun 10 '14 at 20:48

12.04 and later - Unity

The Unity Launcher auto-hide option is now a System Setting - Appearance option: By default, auto-hide is switched off - in previous versions of Ubuntu these behaviour was reverse.

enter image description here

From the Behaviour tab you have the option to switch-on autohiding of the Launcher and using the slide-bar to control the responsiveness to the reveal of the launcher.

enter image description here

You can use the Reveal Location radio-buttons to indicate where you need to position your mouse to reveal the launcher.

The option to switch on autohiding and controlling the hotspot location (left edge/top left corner) is on the Behaviour tab.

Unlike previous versions of Ubuntu, the dodge windows option has been removed due to User testing that showed that this form of autohiding caused confusion.

12.04 & Unity-2D

The Unity-2D Launcher delay is now a System Setting - Appearance option:

enter image description here

From the Behaviour tab you have the option to switch-on autohiding of the Launcher and by clicking the Low/High buttons to control the responsiveness to the reveal of the launcher.

enter image description here

You can use the Reveal Location radio-buttons to indicate where you need to position your mouse to reveal the launcher.

By default the auto-hide nature is toggled off meaning the launcher is permanently visible.


Linked Question:

11.04 & 11.10

You can disable the autohide feature of the Unity launcher by following these simple steps:

WARNING: CCSM is an advanced tool and using it may break your Unity. To avoid this, follow the steps exactly as mentioned here

  • Install the CompizConfig Settings Manager package via the Ubuntu Software Centre

Installing the Compiz settings manager

  • Once installed, open the settings manager and scroll down until you see the 'Ubuntu Unity Plugin' which is located in the Desktop category.

The Compiz settings manager

  • Set 'Hide Launcher' to 'Never'.

Changing the Launcher autohide settings

  • The settings will have automatically applied and the launcher will now be locked in place.
  • The Compiz Config Settings Manager can break things See the answer of jackocnr to learn how to do this with standard gnome means. – cfi Mar 17 '12 at 15:23
  • This question was obviously answered before the launcher changes made in Unity. – Lee Jarratt Mar 27 '12 at 11:22
  • dodge windows would be nice. I got back to Unity (Ubuntu 16.04) and i miss this option. I want autohide but not when I am on desktop. – Mich. Gio. Nov 26 '17 at 8:33

If you don't have Compiz Config installed, you can still do this very easily. Launch gconf-editor by hitting Alt+F2 and then typing it and hitting Enter.
Navigate to /apps/compiz-1/plugins/unityshell/screen0/options and then set launcher_hide_mode to 0.

With Compiz Config (ccsm) installed, go to the Ubuntu Unity Plugin, now you will see a drop-down menu next to the words Hide Launcher, click on the drop down menu and select Never and that is it, Unity launcher will no longer hide.

  • Well, it always shows the launcher now, but windows get maximised behind it. Can that be fixed? – Bart van Heukelom Apr 28 '11 at 14:45
  • 1
    Oh, and on dual monitors, windows on the secondary screen maximise very strangely (full height, 20 px wide, on the edge) – Bart van Heukelom Apr 28 '11 at 14:56
  • I've "fixed" both issues by picking the left monitor as the primary, instead of the right, which it apparently can't handle very well. – Bart van Heukelom Apr 29 '11 at 9:12
  • @Bart van Heukelom, how do you make a monitor primary? – James McMahon Sep 23 '11 at 15:43
  • @James McMahon With the Nvidia config tool – Bart van Heukelom Sep 24 '11 at 22:21

16.04 CLI one liner

dconf write /org/compiz/profiles/unity/plugins/unityshell/launcher-hide-mode 1

0 is the default value for auto-hide off.

Found with:

dconf watch /

then changing it from GUI.

You can auto-hide the Unity Launcher. Follow the below steps to do so.

  • First open the System Setting. system setting

  • Now Click on Appearance icon in Personal group.

  • Now a window similar to below one can be seen. appearance window
  • You can see that the auto-hide feature is turned OFF by default in my version(16.04).
  • You are there! Click on the toggle switch to turned the feature ON.

You can see that Unity-Launcher auto-hides when cursor is off from it.

You can do the same in Ubuntu versions above 12.04

You'd have to edit the source & rebuild unity. Haven't checked this in some time, (natty), bit I believe it;s defined in unity/plugins/unityshell/src/LauncherHideMachine.cpp, possibly here (this is from unity-5.2 source

_hide_delay_timeout_length = 750;

17.10

In Ubuntu 17.10, open Settings (can press windows/super key and search for settings) and then toggle the Auto-hide the Dock option under Dock.

Dock Settings

protected by Community Nov 13 '11 at 15:35

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.