14

After I installed Ubuntu 17.10 and installed Unity instead of Gnome keyboard shortcuts stopped working. For example I cannot launch terminal with Ctrl+Alt+T or change language using keyboard. It is interesting that simple shortcuts, which involve only one modifier key (like Alt+F4) work and the same applies not only to the OS but to the applications as well.

The volume keys and other special keys on the keyboard are not working as well.

1
2

I ran into this issue too with an update to Ubuntu 17.10 and switch to Unity.

To get Ctrl+Alt+T to spawn a gnome-terminal I started ccsm and went to the "Commands" item in the "General" section entering /usr/bin/gnome-terminal in "Command line 0" under the "Commands" tab and set Ctrl+Alt+T for "Run command 0" under the "Key Bindings" tab. The "Commands" item also needs to be enabled with the tick mark.

In unity-control-center under "Keyboard" and "Shortcuts" tab the "Launch terminal" in the "Launchers" section now displays "Disabled".

1
  • Works perfectly : bypassing the unity bug. – Tinmarino May 1 '18 at 11:32
-2

I resolved it by reinstalling Ubuntu. It is for sure not the best solution, but I found no other option. It was too annoying for me.

Maybe I damaged some packages while switching from Gnome to Unity and trying to remove Gnome, and that caused issues with shortcuts.

3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.