0

I know there are tons of post similar to this but I am unable to find a solution to my problem. I just made a clean install of Ubuntu 17.10 ( cause I mess things with my Nvidia drivers and I decided to start over ). I have two identical monitors 21.5' full HD which I use but the second one has a fixed resolution of 1024x768. I tried to use both Nvidia drivers or default drivers without any result. As you will see it can't detect my second display at all.

enter image description here

Both monitors are plugged into the same GPU which is Nvidia GTX 950. The GPU has one DisplayPort, one HDMI, and one DVI-I input.

  • The primary display uses a VGA to HDMI cable ( from Monitor to GPU)
  • The second uses a VGA to DVI-I ( using a VGA to DVI adapter )

Below there is some information which might help.

xrand output :

Screen 0: minimum 320 x 200, current 2944 x 1080, maximum 8192 x 8192
XWAYLAND0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 480mm x 270mm
   1920x1080     59.96*+
XWAYLAND1 connected 1024x768+1920+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768      59.92*+

lshw -c video output :

  *-display                 
       description: VGA compatible controller
       product: GM206 [GeForce GTX 950]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:123 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:c0000-dffff

My drivers :

enter image description here

What I have already tried with failute :

Using the information on the ubuntu wiki I tried to set the desire resolution manually following the commands below :

~$ cvt 1920 1080
# 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
~$ xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
~$ xrandr --addmode XWAYLAND1 "1920x1080_60.00"
~$ xrandr --output XWAYLAND1 --mode "1920x1080_60.00"
xrandr: Configure crtc 1 failed

In case I use the Nvidia binary drivers from the Additional Drivers menu and do the same commands I will get "X Error of failed request: BadMatch (invalid parameter attributes).." error, I already test it before making a clean install.

I try to use Arandr software which someone suggests on similar posts but still getting the same error.

Sorry for the long post. I tried to give as much information as I could.

1

After a lot of search, I found a workaround ( or fix if I may call it). Here are the steps I did to fix it.

  1. I disabled the Nvidia drivers from Software & Updates -> Additional Drivers
  2. Having two identical monitors ( same vendor etc ) I acquire EDID of the working monitor
  3. I generated the X configuration file through Nvidia settings window
  4. I manually modified the xorg.conf file (located at /etc/X11/xorg.conf) and on the "Screen" section I added the following option : Option "CustomEDID" "CRT-0:/myfullPath/edid.bin where 'CRT-0' is the previously name of my monitor assigned by the Nvidia and the edid.bin is the EDID file of the working monitor.
  5. then I made a reboot and everything was working fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.