Because PPA's don't have an actual bug tracker and they're pretty badly maintained, I figure I would just ask how to fix this here.

The package libvlccore9 in the vlc-master PPA is trying to install /usr/lib/x86_64-linux-gnu/libvlccore.so.9.0.0 which is supposed to be installed by libvlccore8.

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libodbcinstq4-1 vlc-bin vlc-l10n vlc-plugin-notify vlc-plugin-qt vlc-plugin-samba vlc-plugin-skins2 vlc-plugin-video-splitter vlc-plugin-visualization
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  libvlccore9
0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
34 not fully installed or removed.
Need to get 470 kB of archives.
After this operation, 1,243 kB of additional disk space will be used.
Get:1 http://ppa.launchpad.net/videolan/master-daily/ubuntu artful/main amd64 libvlccore9 amd64 3.0.0~rc1~~git20171213+r73247+108~ubuntu17.10.1 [470 kB]
Fetched 470 kB in 1s (279 kB/s)      
(Reading database ... 322201 files and directories currently installed.)
Preparing to unpack .../libvlccore9_3.0.0~rc1~~git20171213+r73247+108~ubuntu17.10.1_amd64.deb ...
Unpacking libvlccore9:amd64 (3.0.0~rc1~~git20171213+r73247+108~ubuntu17.10.1) ...
dpkg: error processing archive /var/cache/apt/archives/libvlccore9_3.0.0~rc1~~git20171213+r73247+108~ubuntu17.10.1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libvlccore.so.9.0.0', which is also in package libvlccore8:amd64 3.0.0~~git20171208+r73126+99~ubuntu17.10.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libvlccore9_3.0.0~rc1~~git20171213+r73247+108~ubuntu17.10.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

question is why is that, libvlccore8 doesn't show that file,

apt-file show libvlccore8
libvlccore8: /usr/lib/x86_64-linux-gnu/libvlccore.so.8
libvlccore8: /usr/lib/x86_64-linux-gnu/libvlccore.so.8.0.0
libvlccore8: /usr/share/bug/libvlccore8/control
libvlccore8: /usr/share/bug/libvlccore8/presubj
libvlccore8: /usr/share/doc/libvlccore8/NEWS.Debian.gz
libvlccore8: /usr/share/doc/libvlccore8/changelog.Debian.gz
libvlccore8: /usr/share/doc/libvlccore8/copyright

I have a libvlccore8

dpkg -l | grep -i libvlccore
rc  libvlccore7                                   2.1.6-0ubuntu14.04.1                            amd64        base library for VLC and its modules
ii  libvlccore8:amd64                             3.0.0~~git20171208+r73126+99~ubuntu17.10.1      amd64        base library for VLC and its modules

But I can't even remove it in the current state,

sudo apt-get --purge remove libvlccore8
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libvlc5 : Depends: libvlccore9 (>= 3.0.0~rc1~~git20171213+r73247+108~ubuntu17.10.1~) but it is not going to be installed
 phonon4qt5-backend-vlc : Depends: libvlccore8 (>= 2.0.0) but it is not going to be installed
 vlc-plugin-base : Depends: libvlccore9 (>= 3.0.0~rc1~~git20171213+r73247+108~ubuntu17.10.1~) but it is not going to be installed
                   Depends: vlc-plugin-abi-4-0-0
 vlc-plugin-notify : Depends: libvlccore9 (>= 3.0.0~rc1~~git20171213+r73247+108~ubuntu17.10.1~) but it is not going to be installed
                     Depends: vlc-plugin-abi-4-0-0
 vlc-plugin-qt : Depends: libvlccore9 (>= 3.0.0~rc1~~git20171213+r73247+108~ubuntu17.10.1~) but it is not going to be installed
                 Depends: vlc-plugin-abi-4-0-0
 vlc-plugin-samba : Depends: libvlccore9 (>= 3.0.0~rc1~~git20171213+r73247+108~ubuntu17.10.1~) but it is not going to be installed
                    Depends: vlc-plugin-abi-4-0-0
 vlc-plugin-skins2 : Depends: libvlccore9 (>= 3.0.0~rc1~~git20171213+r73247+108~ubuntu17.10.1~) but it is not going to be installed
                     Depends: vlc-plugin-abi-4-0-0
 vlc-plugin-video-output : Depends: libvlccore8 (= 3.0.0~~git20171208+r73126+99~ubuntu17.10.1) but it is not going to be installed
 vlc-plugin-video-splitter : Depends: libvlccore9 (>= 3.0.0~rc1~~git20171213+r73247+108~ubuntu17.10.1~) but it is not going to be installed
                             Depends: vlc-plugin-abi-4-0-0
 vlc-plugin-visualization : Depends: libvlccore9 (>= 3.0.0~rc1~~git20171213+r73247+108~ubuntu17.10.1~) but it is not going to be installed
                            Depends: vlc-plugin-abi-4-0-0
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

And, i can't run --fix-broken install because then it tries to do the same thing that fails...

apt-get --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libodbcinstq4-1 vlc-bin vlc-l10n vlc-plugin-notify vlc-plugin-qt vlc-plugin-samba vlc-plugin-skins2 vlc-plugin-video-splitter vlc-plugin-visualization
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libvlccore9
The following NEW packages will be installed:
  libvlccore9
0 upgraded, 1 newly installed, 0 to remove and 3 not upgraded.
34 not fully installed or removed.
Need to get 0 B/470 kB of archives.
After this operation, 1,243 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 322201 files and directories currently installed.)
Preparing to unpack .../libvlccore9_3.0.0~rc1~~git20171213+r73247+108~ubuntu17.10.1_amd64.deb ...
Unpacking libvlccore9:amd64 (3.0.0~rc1~~git20171213+r73247+108~ubuntu17.10.1) ...
dpkg: error processing archive /var/cache/apt/archives/libvlccore9_3.0.0~rc1~~git20171213+r73247+108~ubuntu17.10.1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libvlccore.so.9.0.0', which is also in package libvlccore8:amd64 3.0.0~~git20171208+r73126+99~ubuntu17.10.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libvlccore9_3.0.0~rc1~~git20171213+r73247+108~ubuntu17.10.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
  • Try removing all the packages that depend on libvlccore9, then Apt should no longer want to install it, and you can remove libvlccore8. – fkraiem Dec 17 '17 at 2:24

I had this same issue. Try these steps:

sudo dpkg --purge libvlccore8
sudo apt-get --fix-broken install
sudo apt-get update
sudo apt-get -y upgrade
  • this of course doesn't work. I even tried --fix-broken install in the question. And, all of these were run after apt-get update. The problem is the VLC PPA repo was broken, not that my cache was out of date. – Evan Carroll Dec 18 '17 at 14:16
  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. - From Review – derHugo Dec 18 '17 at 14:55
  • 1
    @derHugo: Looks like an (attempt) at an answer to me. If you disagree with the answer please use the vote function. – David Foerster Dec 18 '17 at 20:59
  • I think you didnt read the solution properly. First step was to remove the libvlccore8. Then running --fix-broken install resolved for me. – Abhishek Salian Dec 19 '17 at 0:20
  • Confirmed working, I only ran the first line followed by apt-get -f install, and upgrade completed successfully. Cheers. – Julian H. Lam Dec 28 '17 at 16:31
up vote 3 down vote accepted

To resolve these issues I ran

rm -rf /usr/lib/x86_64-linux-gnu/libvlccore.so.9.0.0
apt-get --purge --yes remove '*vlc*'

This heavy handed approach eventually removed all traces of VLC. From that point, I thought I could re-add it. But then, likely the real problem all along, emerged. The internal version strings in the PPA were borked.

In order to get your system into a consitent state you must manually delete libvlccore.so.9.0.0, without which dpkg can not proceed.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.