0

When I try to upgrade to 16.04 by running...

sudo do-release-upgrade

...I see a lot of messages about broken items, starting with libnss3-nssdb...

 Investigating (0) libnss3-nssdb [ amd64 ] < 2:3.23-0ubuntu0.15.10.1 > ( admin )
    Broken libnss3-nssdb:amd64 Depends on libnss3 [ amd64 ] < 2:3.28.4-0ubuntu0.16.04.3 > ( libs ) (= 2:3.23-0ubuntu0.15.10.1)
      Considering libnss3:amd64 46 as a solution to libnss3-nssdb:amd64 11
Removing libnss3-nssdb:amd64 rather than change libnss3:amd64

There are many other lines like this, and the first few reference libnss3. I also was getting an error re: libnss3 any time I try upgrading or installing a package with apt, which is what has prompted me to attempt the upgrade to 16.04 LTS.

10
  • Are there things you need on 15.10? If not perhaps a fresh install of 16.04 might be in order! Dec 14, 2017 at 15:44
  • George, that is not a terrible idea. I may go that route. Though I would have a substantial amount of software to reinstall, databases to import, etc.
    – arnoldbird
    Dec 14, 2017 at 17:31
  • Run this first sudo apt-get update && sudo apt-get dist-upgrade thenn try the upgrade again Dec 14, 2017 at 19:01
  • No such luck: root@my-desktop:~# apt dist-upgrade Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these. The following packages have unmet dependencies: libnss3-nssdb : Depends: libnss3 (= 2:3.23-0ubuntu0.15.10.1) but 2:3.28.4-0ubuntu0.16.04.3 is installed E: Unmet dependencies. Try using -f.
    – arnoldbird
    Dec 14, 2017 at 22:56
  • Please don't expect there to be a single command to solve your issue lets correct them one at a time, run sudo apt-get install -f, then try again! Dec 14, 2017 at 22:59

1 Answer 1

0

You need to fix the dependency version.

Try using: sudo apt-get install libnss3=2:3.23-0ubuntu0.15.10.1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .