2

Good day fellow Ubuntu people, I have a similar bluetooth problem not detecting any devices

I installed ubuntu version 16.04 on hp 4520s laptop and want to connect a bluetooth keyboard i have tried finding device normally like i have done on other ubuntu laptops and can't see the device at all, I then tested to see if the laptop detects any other devices like my phone and stil no devices are visible i also checked if i can connect keyboard to a windows laptop and i am capable of finding the device and connect to it.fault so far i have determined lies with the either faulty hardware or firmware on ubuntu laptop i have also tried installing other bluetooth managers like blueman appplet in ubuntu and stil cannot find any devices.THis is how far i have come.I am new to ubuntu forums and any advise help would be appreciated

Here, below lists of system information.

rfkill list:

0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: hp-wwan: Wireless WAN
    Soft blocked: no
    Hard blocked: no
4: hp-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no

lspci -knn | grep Net -A2; lsusb:

Bus 002 Device 005: ID 148f:1000 Ralink Technology, Corp. Motorola 
BC4 Bluetooth 3.0+HS Adapter

dmesg | grep -i blue:

[  177.053159] Bluetooth: Core ver 2.22
[  177.053185] Bluetooth: HCI device and connection manager initialized
[  177.053188] Bluetooth: HCI socket layer initialized
[  177.053190] Bluetooth: L2CAP socket layer initialized
[  177.053196] Bluetooth: SCO socket layer initialized
[  177.993897] Bluetooth: hci0 hardware error 0x37
[  189.515605] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[  189.515607] Bluetooth: BNEP filters: protocol multicast
[  189.515611] Bluetooth: BNEP socket layer initialized
[  220.258415] Bluetooth: RFCOMM TTY layer initialized
[  220.258425] Bluetooth: RFCOMM socket layer initialized
[  220.258433] Bluetooth: RFCOMM ver 1.11
1
  • Added broader description of problem hope it helps. – Nicolaas Uys Dec 15 '17 at 13:14
1

You can use this:

sudo bccmd psset -s 0x0000 0x028c 0x0001

And:

sudo service bluetooth restart
1
  • sorry, i'm just sharing a solution I saw in another question – Leonardo Pereira Jul 26 '19 at 14:37
0

After reboot bluetooth adapter was not detected by bluez. Tried to restart the service, did not work. Reloading module helped

sudo rmmod btusb
sudo modprobe btusb
sudo service bluetooth restart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.