6

The screen lock is not working, it does not lock the screen (no password required).

I would like it to prompt for a password every time the screen locks (clock screen).

All instructions tells me to enable this in privacy but I can not enable or disable as it's grey (gray).

Ubuntu 17.10 upgraded from Ubuntu 17.04, upgraded from Ubuntu 16.10.

Screen Lock Grey out

Any help or advise would be great as I already tried many setting and installs and removes suggested on online.

8

Lock screen needs to be enabled:

gsettings get org.gnome.desktop.lockdown disable-lock-screen
false

If result is true then use:

gsettings set org.gnome.desktop.lockdown disable-lock-screen false
  • Brilliant that worked as explained what i don't understand is why do we need to run commands to enable something in a GUI... Anyway many Thanks – gcclinux Feb 1 '18 at 15:09
  • @gcclinux You actually can install a GUI with sudo apt install. Then use the GUI to control the setting. However the instructions take longer for me to create and bloats the user's drive. If you wouldn't mind accepting the answer by clicking the check mark to let others know the solution works. It also reduces the number of questions unsolved in the database. – WinEunuuchs2Unix Feb 1 '18 at 23:42
  • I agree with @gcclinux. This should be enabled by default....its a feature of the OS and even has a predefined Keyboard Shortcut (Super + L). – danielricecodes Mar 1 '19 at 20:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.