2

Recently when i have booted up my computer the login-screen has been black, no background image. But in difference to other questions on here that i find, in case the user-selection remains visable (see image - sorry for bad quality, could not do a print-screen)

My Login-Screen

The problem started after i changed the background image for my login-screen (trough the settings-menu), instead of the new image of my choosing, it turned black, and then i tried to change back trough the Settings Menu again - nothing happened and now i'm stuck with the black screen. The background image does return if i log-out again after i have logged-in, but if i reboot the computer it's back to black again every time.

I'm using Ubuntu Budgie as my Distro of choice, if that changes anything? Would be happy for any help and/or advice!

4
  • please add to your question how you tried to change the background image - i.e. the commands that you used.
    – fossfreedom
    Commented Dec 28, 2017 at 23:40
  • Added! Thanks for pointing that out Fossfreedom! Commented Jan 3, 2018 at 1:17
  • So how did you change the background image in the beginning?
    – fossfreedom
    Commented Jan 3, 2018 at 9:09
  • Used the standard settings-menu that the OS came with in both cases. Commented Jan 4, 2018 at 13:32

2 Answers 2

2

I had the same issue and figured out why it happens. The fix is quite simple.

When you choose a picture from your home directory, you as set as the owner of this picture (check with ls -al).

Lightdm uses its own user and must be allowed to read the image from your home directory. To avoid black screens, make sure that "other users" have read permission.

you can use this command to fix the rights:

chmod 644 /home/path/to/the/image.jpg
  • 6 = I can read and write the image
  • 4 = Others can read the image

Regards,

Obibann.

0
1

I installed Ubuntu Budgie 22.04 and after some updates that where aplaied on October I'd get the black login screen.

I change the background image with lightdm-settings package and I made a symlink at /usr/share/backgrounds/ to ~/Images/wallpapers.

In order to discard problems with nvidia drivers I tried to change the background image with a default image in /usr/share/backgrounds/budgie and that worked.

Then as Obibann's said I check to the folders and images permissions and change them to 755 to folders and 744 to images but I'd still get the black login screen. Then I found out that my user folder had 754 permissions, so I change it to 755 and that solved my problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .