1

I am new to Ubuntu and I am trying to install pgadmin4 with

pip install pgadmin4-1.4-py2.py3-none-any.whl

But received the following error while installing pgadmin4:

Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-6FWQnT/psycopg2/

enter image description here

Can someone please assist or give advice on how to rectify this error?

Also, I tried to find the

config_locale.py

file in order to configure the file in accordance with this sites instructions, but there was no such file. Should I post another query or may I ask if someone can help me to locate the file?

1

I have also facing this issue today. at first psycopg2==2.6.2 have some bug/issues, that's why we were faceing this type of issues. so you need to install latest version of psycopg2 by using following command.

pip install  pgadmin4-1.4-py2.py3-none-any.whl  -U psycopg2

This command will install all the dependencies and install upgraded version of psycopg2.

Secondly config_locale.py file will create after this installation process complete.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.