1

I am running ubuntu 14.04 with nodejs on Amazon EC2 micro instance. I enabled both ports in EC2 config:

enter image description here

I have both apps running on both 80 and 3000 ports:

enter image description here

Port 3000 is available from outside but port 80 is not whatever I tried:

enter image description here

Please help me understand what blocks the port.

  • I think you should check your security group settings and also nginx config. – M. Dm. Dec 13 '17 at 14:39
  • @M.Dm. all security group settings are "Inbound Rules" which I showed you and nginx config should not be the issue as I tried apache and it didn't work as well – Eugene Dec 13 '17 at 14:45
  • can you attach the output of sudo netstat -tnlp? – M. Dm. Dec 13 '17 at 14:53
  • @M.Dm. prntscr.com/hmztrt – Eugene Dec 13 '17 at 15:10
  • Could you please post text files, dialogue messages, and program output listings as text, not as images? – pomsky Dec 13 '17 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.