I run my Ubuntu in a VMWare virtual machine that is hosted by Win10. Vmware tools is installed.

I can't copy from notepad in Windows and paste into Ubuntu applications. Vice versa works fine. The virtual machine settings for copy/paste - enabled:


How to enable copy from Windows 10 and paste to Ubuntu.

1 Answer 1


Feels like I found an answer (I used it for 17.10 )

In the terminal window execute this command to remove any previously installed tools:

sudo apt-get autoremove open-vm-tools

and after that execute this command to add tools:

sudo apt-get install open-vm-tools-desktop

and a final thing: do not forget to reboot.

It worked very well for me!

  • I dit it. It works... but copy-past file doesn't work from host(Debian 10) to guest(Debian 10). Copy-past files works only from guest to host. Any ideas?
    – rulet
    Dec 26, 2019 at 11:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.