35

I'm trying to get an Ubuntu VM to run well in the latest VirtualBox (5.2.2), which I installed by running sudo ./VboxLinuxAdditions.run. The problem is I keep getting this error message when the VM starts:

VBoxClient (seamless): failed to start. Stage: Setting guest IRQ filter mas Error: VERR_INTERNAL_ERROR

Ubuntu on Ubuntu in VirtualBox is extremely frustrating

The host is Ubuntu 16.04.3. I've tried two Ubuntu 17.10 distros (Lubuntu and Budgie). Both failed with the same error.

Being unable to run Ubuntu on Ubuntu should be a P0 critical issue for Oracle. What am I doing wrong?

  • 1
    How did you install the guest additions? – George Udosen Dec 13 '17 at 10:58
  • @GeorgeUdosen: that was it. Updated the Q and added an answer. Thanks! – Dan Dascalescu Dec 13 '17 at 20:58
42

Turns out I had to install gcc, make and perl, then reinstall the additions and reboot:

sudo apt-get install gcc make perl
cd /media/$USER/<...>
sudo ./VBoxLinuxAdditions.run
sudo reboot
  • 2
    Worked for me as well! Thanks (Ubuntu 16.04.3 w vboxgas & virtualbox 5.2.6)! – Ignorante Jan 26 '18 at 22:02
  • 1
    This worked well. The first line fixed the issue; the last three re-install Guest Additions (which can be done in the GUI as well) – User that is not a user Feb 19 '18 at 19:58
  • 1
    Also worked for me. I noticed that it took much longer for the Guest Additions to install once gcc, make, and perl were installed. Without them, I guess lengthy steps were being skipped. Is there a VirtualBox bug in here? Seems like it should give you an error if vital components are missing. – Aren Cambre Apr 10 '18 at 14:55
  • 2
    Kernel headers are mandatory too (linux-headers-amd64 or the like). All errors are logged in a sub-log, which makes it difficult to understand why this fails. The run script should dump what tools are missing. – Yvan May 8 '18 at 2:05
  • Yay thank you! 16.04 x64 on VB 5.2.12 on OSX 10.13.5. I wasted hours on other, longer, slower, very different solutions to get guest-host clipboard sharing to work. Gotta learn to just askubuntu... Gotta say, we're an advanced technological civilization, and we're all pretty technical. Why does it feel like we're 100,000,000 amoebas in a pond? – Spike0xff Jun 19 '18 at 21:06
5

I am on Mac OSX 10.14.3 and working with Virtualbox 5.2.22 and Ubuntu Desktop 16.04.6 virtual machine. In my case, I'm running Ubuntu in 32bit mode because I had trouble getting 16.04 to work in 64bit mode. I recently upgraded to kernel 4.4.0-143 using the typical Ubuntu update and then, when I restarted the VM again, I got this VBoxClient seamless error just like you see here. After trying all kinds of things, such as upgrading Virtualbox, upgrading VBox Extensions, and more -- the resolution was that I rebooted the VM, held the shift key down, and chose kernel 4.4.0-142. Then, I got the error, but was able to run:

sudo apt-get install --reinstall build-essential virtualbox-guest-utils virtualbox-guest-x11 virtualbox-guest-dkms

That, of course, would put the wrong virtualbox stuff on my VM, but was actually useful because then I could force the kernel to switch to the proper vbox extensions in my next step. So, with the command above typed, I rebooted my VM, held shift key down, and chose kernel 4.4.0-142. Now, this made the screen too small because it's not running the optimal virtualbox extensions that support proper screen resize with my Mac driver. Not a problem, though, because this was only temporary. So, I then ran this command:

cd /media/$USER/<...>
sudo ./VBoxLinuxAdditions.run

This properly compiled the vbox extensions that were suitable for my computer. I rebooted the VM, held the shift key down, and chose kernel 4.4.0-142. At that point, the VBoxClient seamless error went away, and I had all my functionality I needed including screen resizing, bidirectional clipboard, mounting shared volumes and so on.

Long story short, the kernel version was at fault, was the best that I could determine. There was something up with the 4.4.0-143 kernel that was causing Virtualbox to choke. Rolling back to a previous kernel and forcing vbox extensions to reinstall was my fix for now.

EDIT: This evidently is a tracked bug with a proposed fix coming soon (it's Mar 19, 2019) for Ubuntu 16.04. It's in patch review mode, currently. More info: https://bugs.launchpad.net/ubuntu/+source/virtualbox/+bug/1818049?comments=all

3

In addition to ensuring make, gcc and perl are installed as per Dan's accepted answer it may be necessary to also check for version-specific kernel headers linux-headers-$(uname -r), build-essential and dkms. Catch-all one-liner:

sudo apt install gcc make perl linux-headers-$(uname -r) build-essential dkms 

I ran into this issue while I had the first three package installed. Installing the rest resolved it. It's possible that not all are necessary, but notably only installing the linux-headers package (without version specified) was not enough.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.