1

I've just installed Ubuntu 17.10, because it has xserver 1.19.x and up to date kernels for nvidia prime synch for my dedicated card in my laptop.

But it keeps randomly freezing. Mouse moves, but can't interact with anything. Everything is frozen, no keyboard commands respond. I have to hard restart my laptop.

I had issues with prime sync not working, so after contacting support I've disabled Wayland and use xorg, now it finally does and I have no screen tear issues. (in /etc/gdm3/custom.conf uncomment the line #WaylandEnable=false)

I've read in a similar problem that it's maybe because of gnome wanting wayland?

I have gnome extension installed as well. Tweak tool and Ark theme, Paper Icon pack.

Can I fix this by changing from gnome to something else? Is it supported in 17.10?

What can I do to stop this issue?

  • Try to write down the exact time when problem occurs. Then after rebooting, cd /etc/log (the logs folder) then ls -tl to sort by time (newest first) and see which log files have been updated since the time of the issue. Then look in those 5 or so files and find messages from at or near the time your system froze (each line starts with a timestamp). Then paste those in your question and/or search the web with the likely errors. – GlenPeterson Dec 13 '17 at 0:31
  • Does everything work if you use different video drivers (or the default drivers)? – GlenPeterson Dec 13 '17 at 0:31
  • Rather than mess around with /etc/log/, you can get the aggregated system logs from journald, which provides a more featured interface: $ journalctl -xe – Andrew Keech Dec 13 '17 at 5:09
0

So, after switching to another flavour of Ubuntu this problem was gone (mostly).

I'm using Kubuntu (KDE) now and I don't experience any freezes. I'll assume this bug was because of GNOME.

I only expeirenced one freeze with KDE, when I installed some 'restoreconf' or similar package...don't quite remember. Uninstalled it, the problem was gone. I think that package comes with ubuntu gnome version by default and not with kde...not sure.

But I'll leave this here. If you have freeze problems with GNOME if you disable wayland, switch to another DE and it should be gone. Really disappointed how unstable it is.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.