0

I've been working with Ubuntu for approximately 2 years.

First my Ubuntu OS crashed and I was directed to initramfs page where it demanded I run fsck manually. Later my Windows OS also crashed and I was taken to a grub rescue> page (rescue mode).

So my friend suggested I use a Live Ubuntu Boot. I used a pen drive and I got my Windows OS running again.

The problem is that in the Ubuntu trial version, i. e. Try Ubuntu, I still can't access my Ubuntu files (pdfs, videos and stuff).

An Image of my GParted partitions

The sda4 drive which it is showing in my case (check GParted) when I try to unmount it on terminal it says:

Terminal Partitions

umount: /dev/sda4: not mounted

Am I using some ghost space?

Please help me get my files back!

  • you may have major problems .. I hope you havent touched the drive since this has happened .. maybe there is a way to recover but I think your partition table got messed up. Im not fully sure about this and their may be a fix but I dont think you can mount the "extended" partition .. its a "holder" .. there should be a partition under the extended one...but as I dont know if its savable or not but don't touch the drive until you have some other input from someone who knows more about this problem or you may lose the partition for good and the files.as shown here – John Orion Dec 12 '17 at 20:26
  • You are well outside the zone of Ubuntu support. You seem to be in the zone of data recovery. If the lost files are valuable to you, and if you lack backups, a paid data recovery service may be worthwhile to call before you overwrite the files with further use. – user535733 Dec 12 '17 at 21:36
  • Could you please post text files, dialogue messages, and program output listings as text, not as images? To achieve the latter two you can either 1) select, copy & paste the dialogue text or terminal content or 2) save the program output to a file and use that. Longer listings (the editor will tell you what's too long) should be uploaded to a pastie service and linked to in the question. Thanks. – David Foerster Dec 13 '17 at 13:44
  • You can try to recover the partition (and file system) according to the following link with Testdisk, and if that does not work to recover the file data directly 'from the drive surface' with PhotoRec, askubuntu.com/questions/982552/accidentally-did-dd-dev-sda/… – sudodus Dec 13 '17 at 14:13
2

The space that I presume once contained your Ubuntu installation (51.86 GiB) shows unallocated. That means that partition has been deleted. Officially, everything in it is gone. The one you're trying to mount, /sda4, is the extended partition that contains the logical volumes that once held your Ubuntu and still hold its swap. It was never mountable.

Unofficially, you may still be able to recover the contents, if you can create a new partition with exactly the same parameters as the one that used to be there. However, you'll then be in the position of having partitions out of order on the hard disk, which is also bad -- and you can't just delete the swap partition, because it's holding the space that might let you recreate the missing partition.

What I would attempt is to create a new partition (it'll be assigned /sda6) in the empty space before /sda5, and then delete /sda5. Later, you may be able to recreate the swap (it'll now be designated /sda7). DO NOT format the new /sda6 partition when you create it, but be sure you use the same filesystem type you had before (be that ext4, ntfs, btrfs, or whatever else). Also, check the box to make the partition bootable.

After you've done all this, restart on your Live USB and see if you can mount the new sda6; if so, you will then be able to correct GRUB and the /etc/fstab in that partition to point to the correct partition (UUID will have changed, even if you're using that method).

IFF everything has gone well to this point, you'll be back where you were before your Windows quit working, with (at least) the data in your /home recoverable (you'll probably still need to reinstall Ubunbtu to undo the crash that started all of this).

There's no guarantee this will work -- I've recovered contents by recreating a deleted partition, but I did it under DOS 3.31 with fdisk, when that was a current operating system. I've never tried it since. On the other hand, it won't make things any worse than they are now.

Not the answer you're looking for? Browse other questions tagged or ask your own question.