I'm trying to run Ubuntu off of a USB. The exact error message read as follows:

SYSLINUX 6.03 EDD 2014-10-06 Copyright (C) 1994-2014 H. Peter Anvin et al

Failed to load ldlinux.c32
Boot failed: please change disks and press a key to continue.

I followed these instructions (multiple times, same result) to create the USB stick: https://tutorials.ubuntu.com/tutorial/tutorial-create-a-usb-stick-on-windows#0

I followed these instructions for booting the computer: https://tutorials.ubuntu.com/tutorial/try-ubuntu-before-you-install?backURL=%2F#0

I used a brand-new 16GB USB 3.0 from PNY. I installed it using a Windows 7 Dell laptop (BIOS), which was unable to boot it from the USB. I tried booting it on a Windows 10 Dell desktop (BIOS) with the same result. I was using the latest LTS ISO from Ubuntu.com (ubuntu-16.04.3-desktop-amd64).

I tried writing in the ISO image mode multiple times with the same result before trying the DD image mode, which threw a "corrupt file" error and then wiped the USB entirely blank, so I slow-formatted it in FAT32 on my next attempt (instead of the instruction's usual "quick format" option).

Some people said they had success copying ldlinux.c32, libcom32.c32, and libutil.c32 to the root directory, but that didn't change a thing for me. I tried formatting the USB as NTFS as well as FAT32. Same result. Some people said that FAT16 fixed it for them, but that wasn't an option in Rufus.

I'm totally lost! Here I was, trying to learn Linux, and I'm unable to even boot it! Help, please?

EDIT: Not sure why it's being marked as duplicate. The questions it's supposedly identical to have nothing to do with this specific error message.

  • 1
    Have you verified the checksum of the ISO file? Dec 12, 2017 at 15:25
  • 1
    Also, if the checksum does in fact match try Universal USB Installer instead of Rufus. You may also consider just burning it to a blank DVD with the ISO burner program built-in to Windows Dec 12, 2017 at 15:29
  • 1
    This looks like a known bug, that occurs with some versions of Ubuntu and some tools to create USB boot drives. Cloning tools are not affected by this bug, only some extracting tools, for example old versions of Unetbootin and the Ubuntu Startup Disk Creator (new versions of those tools work). Rufus, Win32DiskImager, mkusb, Disks (alias gnome-disks) work. Do you want to create a live-only, a persistent live or an installed system in your USB drive? The following link (and links from it) might help, ubuntuforums.org/showthread.php?t=2230389
    – sudodus
    Dec 12, 2017 at 16:06
  • 2
    Once a problem is solved, please don't edit your question to add the solution or the title to add solved. Instead, add the solution as an answer below and click the checkmark to mark it solved. Dec 13, 2017 at 2:21
  • Possible duplicate of askubuntu.com/questions/287064/… Dec 15, 2017 at 14:01

2 Answers 2


Thank you, Android Dev! I used the Universal USB Installer instead of Rufus. It threw an error on the first boot-up attempt ("vesamenu.c32: not a COM32R image") which was easily solved by pressing Tab and then typing "live" to select the proper image. I'm now typing this edit on my USB live version of Ubuntu!

  • formating the usb as FAT instead of FAT32 helped me.
    – Raj
    Nov 21, 2019 at 5:02

you can write image with Rufus utility . If your ISO image will latest(in my case 2.16) then it will ask you to download some necessary files to make this ISO bootable. Download that and then make USB bootable. I hope this will solve your problem, or you can use win32 Disk image.

Not the answer you're looking for? Browse other questions tagged .