1

I have a monitor with built-in speakers and headphone & microphone ports. I plug a 3.5mm jack cable into the motherboard's onboard microphone port, and the other end into the monitor, then I can either plug headphones (with separate mic & audio jacks) into the mic & audio jacks on the monitor to listen through headphones, or keep the audio jack disconnected to have audio come out through the speakers.

All was working well until yesterday when I plugged a HDMI cable into my GPU to run a second output to my TV to watch movies on the main TV with audio. Now, I have no audio on the PC. In Volume Control>Output Devices>HD-Audio Generic Analog Stereo, port options are Line Out (Unplugged) and Headphones (Unplugged). If I boot to Windows (10) it works as normal. If I plug the headphone jack directly into the line out port, Volume Control recognises that, changes to Line Out (Plugged In) and it works. But I don't understand why it'll no longer give me the option to output audio and input microphone via the microphone port? While I've got the headphones plugged into the line out port (with audio working), Volume Control>Input Devices>HD-Audio Generic Analog Stereo, port is Rear Microphone (plugged in)... but there's nothing plugged into the rear microphone. For clarity: if I unplug the (working) headphones from the line out and instead plug in the jack to the monitor (into the Line Out), Volume Control still says Line Out is plugged in... but there's no sounds from the monitor speakers & if I plug the headphones into the monitor headphone port, no sound from them either.

Grateful if anyone has any ideas / thoughts about what might be causing this and what I might do to get back to how things were yesterday? Thanks in advance.

Edit: full disclosure, might not be relevant but plugging the HDMI in seemed to precipitate various problems including setting my home directory to being owned by root, which required fsck from recovery mode, then chmod of various folders. Possibly some config files were disturbed during this event? (e.g. ~./config/pulse ? I don't know much about this stuff at all)

$ pactl list short modules
0   module-device-restore       
1   module-stream-restore       
2   module-card-restore     
3   module-augment-properties       
4   module-switch-on-port-available     
5   module-udev-detect      
6   module-alsa-card    device_id="2" name="usb-Salix_Corp._Trust_Webcam-02" card_name="alsa_card.usb-Salix_Corp._Trust_Webcam-02" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes card_properties="module-udev-detect.discovered=1"  
7   module-alsa-card    device_id="0" name="pci-0000_07_00.1" card_name="alsa_card.pci-0000_07_00.1" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes card_properties="module-udev-detect.discovered=1"    
8   module-alsa-card    device_id="1" name="pci-0000_09_00.3" card_name="alsa_card.pci-0000_09_00.3" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes card_properties="module-udev-detect.discovered=1"    
9   module-native-protocol-unix     
10  module-default-device-restore       
11  module-rescue-streams       
12  module-always-sink      
13  module-intended-roles       
14  module-suspend-on-idle      
15  module-console-kit      
16  module-systemd-login        
17  module-position-event-sounds        
18  module-role-cork        
19  module-filter-heuristics        
20  module-filter-apply     
21  module-switch-on-connect        
22  module-x11-publish  display=:0.0    
23  module-x11-cork-request display=:0.0    
24  module-x11-xsmp display=:0.0 session_manager=local/Poseidon:@/tmp/.ICE-unix/1296,unix/Poseidon:/tmp/.ICE-unix/1296
  • To go back to how your system used to be - find HDMI audio in Pulseaudio configuration and set it to "off". you can use HDMI for video only and audio settings will not change – nik gnomic Dec 18 '17 at 0:03
  • Thanks Nik. Sadly unplugging HDMI cable (leaving only displayport monitor) & plugging in the speakers/mic to mic port then resetting pulse with "rm -r ~/.config/pulse; pulseaudio -k" and restarting, doesn't fix it. I still have output option GP102 HDMI Audio Controller Digital Stereo (HDMI 3) (plugged in) as well as HD-Audio Generic Analog Stereo, with selections lineout & headphones, both unplugged. Input > rear mic is plugged in. Ideally I'd be able to output to monitor speakers/headphones OR HDMI tv, but currently unsure how to force the system to use the mic port as input+output – dez93_2000 Dec 18 '17 at 18:57
  • How about a different cable? Currently it's an output+input cable, hoping to send audio & mic in opposite directions; monitor port is built for this, pc speaker card mic port is CAPABLE of this (worked before, works on win10) but xubuntu/pulse doesn't seem (easily) able to configure this. However, could I buy a splitter cable that takes the monitor's mic + stereo audio and breaks it into separate mic plug & stereo audio plug, such that I can plug em into their expected dedicated ports? I presume this way the system will be configured as expected and should just work? amzn.to/2BFmv8i ? – dez93_2000 Dec 18 '17 at 19:05
  • By removing Pulseaudio configuration with rm -r ~/.config/pulse you keep re-setting to default state. When Pulseaudio restarts it rebuild the files in folder ~/.config/pulse/. need to get Pulseaudio settings corrected and saved. use Pulseaudio Volume Control (pavucontrol), or pactl and pacmd commands in terminal – nik gnomic Dec 20 '17 at 0:40
  • combination jack sockets are annoying - splitter cable is good idea. there is a package hda-jack-retask that can change connections in software, but not something i have used to advise on it – nik gnomic Dec 20 '17 at 0:44
1

Transpires that the question asker is an idiot. The monitor gets its audio for speakers/headphones via the DisplayPort cable, meaning the microphone port on the monitor is connected to the microphone port on the PC via the supplied 3 pin (L/R/GND) 3.5mm jack audio cable, i.e. it's a simple passthrough. Apologies to Nik Gnomic & anyone who read this.

  • 1
    To phrase it as a error code: id-10t would be less painful. – stumblebee Feb 13 '18 at 4:02
  • 1
    no bother - I have been id10t myself plenty of times – nik gnomic Feb 13 '18 at 19:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.